NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2025-70887 — signify

HIGHFix: mtrojnar/osslsigncode#477

CVE-2025-70887 is a high-severity (CVSS 8.8) Improper Privilege Management vulnerability in signify. A fix is available for signify — see the affected versions and patch details below.

Signify allows a remote attacker to escalate privileges via the signed_data.py and the context.py components

Also known asGHSA-p4hh-mq57-gq8xPYSEC-2026-2278
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs29th percentile — riskier than 29% of all scored CVEsHighest risk
0.00%0.28%0.57%0.85%0.2%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍signify

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue in ralphje Signify before v.0.9.2 allows a remote attacker to escalate privileges via the signed_data.py and the context.py components

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIsignifyall versions0.9.2pip install --upgrade 'signify==0.9.2'

Affected Products

1 product · 1 configurations
Application
signifyralphje
< 0.9.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for signify, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update signify to 0.9.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-70887 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

An issue in ralphje Signify before v.0.9.2 allows a remote attacker to escalate privileges via the signed_data.py and the context.py components
O3 Security · Impact-Aware SCA

Is CVE-2025-70887 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2025-70887: signify — Fixed in 0.9.2