CVE-2025-69277 is a medium-severity (CVSS 4.5) CWE-184 vulnerability in paragonie/sodium_compat. A fix is available for paragonie/sodium_compat — see the affected versions and patch details below.
libsodium has Incomplete List of Disallowed Inputs
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-69277.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
paragonie/sodium_compat🐘paragonie/sodium_compat🐍pynacl🐍hdwalletReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist, PyPI packages — download data is not available via public APIs for these ecosystems.
Description
libsodium before ad3004e, in atypical use cases involving certain custom cryptography or untrusted data to crypto_core_ed25519_is_valid_point, mishandles checks for whether an elliptic curve point is valid because it sometimes allows points that aren't in the main cryptographic group.
This advisoory lists packages in the GitHub Advisory Database's supported ecosystems that are affected by this vulnerability due to a vulnerable dependency.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | paragonie/sodium_compat | ≥ 2&&< 2.5.0 | 2.5.0composer require paragonie/sodium_compat:^2.5.0 |
| 🐘Packagist | paragonie/sodium_compat | all versions | 1.24.0composer require paragonie/sodium_compat:^1.24.0 |
| 🐍PyPI | pynacl | all versions | 1.6.2pip install --upgrade 'pynacl==1.6.2' |
| 🐍PyPI | hdwallet | all versions | 3.6.1pip install --upgrade 'hdwallet==3.6.1' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for paragonie/sodium_compat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update paragonie/sodium_compat to 2.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-69277 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated Moderate for Red Hat products as it primarily affects atypical use cases involving custom cryptographic implementations or untrusted data processing with `crypto_core_ed25519_is_valid_point`. Standard libsodium deployments are not expected to be impacted by this flaw.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2025-69277 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Hardened Images | libsodium-main-1.0.22-1.hum1 | RHSA-2026:7369 |
Frequently Asked Questions
Is CVE-2025-69277 in your dependencies?
Find it across Packagist, PyPI, including transitive dependencies.