Hydra legacy target blacklist permits unsafe PyYAML loadingGHSA-wf6j-7hvr-gr93
HIGHFix: hydra-ecosystem/hydra@9a7a9a2GHSA-wf6j-7hvr-gr93 is a high-severity (CVSS 7.8) vulnerability in hydra-core. A fix is available for hydra-core — see the affected versions and patch details below.
Real-World Exposure
hydra-core🐍hydra-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Hydra's legacy target blacklist omits PyYAML's unsafe loading surfaces. If an application passes attacker-controlled targets and arguments to instantiate(), a target such as yaml.unsafe_load can execute Python code through a config-controlled YAML stream containing Python object-construction tags.
Impact and prerequisites
The attacker must control the relevant target and arguments that the application instantiates. The configured callable executes with the application's process privileges. This is a gap in the best-effort legacy blacklist. It is not a bypass of Hydra 1.4's execution whitelist supplied by trusted Python code.
One realistic exposure is a model downloaded from a third-party repository, such as Hugging Face, that bundles attacker-controlled configuration. When a victim loads the model using application code that passes this configuration to legacy Hydra instantiation without effective target restrictions, the model's metadata can execute code in the victim process. This model-loading attack pattern is documented in the original Hydra advisory GHSA-2cp2-2r3c-7p7r and the associated Unit 42 research. It does not imply that all Hugging Face models or currently patched downstream loaders are affected.
Hydra 1.3's blacklist is defense in depth, not a complete security boundary. Hydra 1.4 is affected on its deprecated no-whitelist legacy path. Installed application wrappers can perform indirect operations beyond a name-based blacklist's coverage; this fix does not make arbitrary configuration safe.
The unsafe_load finding is directly reproduced. PyYAML 6.0.3 full_load rejects the demonstrated python/object/apply payload, so the finding does not claim that all PyYAML loading APIs execute that payload.
Remediation
The fix blocks the yaml. target namespace except for the exact yaml.safe_load, yaml.safe_load_all, yaml.safe_dump, and yaml.safe_dump_all functions. Loader classes, constructor registration, general dump/load APIs, and other targets in the namespace remain blocked. Existing canonical-identity checks also cover aliases. The fix preserves Hydra 1.4's explicit unsafe opt-out for trusted use.
Workarounds
Do not pass untrusted configuration to instantiate() or call(). For Hydra 1.4, supply a narrow execution whitelist from trusted Python code. Do not let untrusted configuration select its own execution policy or opt out of checks.
Affected releases
The reported incomplete-remediation stable range is hydra-core 1.3.6 through 1.3.7. The 1.4 prerelease legacy path is also affected, including 1.4.0.dev9, 1.4.0.dev10, 1.4.0rc1, and 1.4.0rc2. The related blacklist advisory GHSA-rqx7-p7vv-w7hr was first patched in 1.3.6 and 1.4.0.dev9; these ranges describe the remaining omission after that remediation.
Credit
Reported by zx (@manus-pi).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | hydra-core | ≥ 1.3.6&&< 1.3.8 | 1.3.8pip install --upgrade 'hydra-core==1.3.8' |
| 🐍PyPI | hydra-core | ≥ 1.4.0.dev9&&< 1.4.0rc3 | 1.4.0rc3pip install --upgrade 'hydra-core==1.4.0rc3' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for hydra-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update hydra-core to 1.3.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wf6j-7hvr-gr93 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-wf6j-7hvr-gr93 in your dependencies?
Find it across PyPI, including transitive dependencies.