NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2025-67818 — weaviate

HIGHFix: weaviate/weaviate@169df2d

CVE-2025-67818 is a high-severity (CVSS 7.2) Path Traversal vulnerability in github.com/weaviate/weaviate. A fix is available for github.com/weaviate/weaviate — see the affected versions and patch details below.

Weaviate OSS has a Path Traversal Vulnerability via Backup ZipSlip

Also known asGHSA-7v39-2hx7-7c43GO-2025-4237
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-67818.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.94%1.41%0.4%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐹github.com/weaviate/weaviate🐹github.com/weaviate/weaviate🐹github.com/weaviate/weaviate🐹github.com/weaviate/weaviate

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Weaviate OSS before 1.33.4. An attacker with access to insert data into the database can craft an entry name with an absolute path (e.g., /etc/...) or use parent directory traversal (../../..) to escape the restore root when a backup is restored, potentially creating or overwriting files in arbitrary locations within the application's privilege scope.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/weaviate/weaviateall versions1.30.20go get github.com/weaviate/weaviate@v1.30.20
🐹Gogithub.com/weaviate/weaviate≥ 1.31.0-rc.0&&< 1.31.191.31.19go get github.com/weaviate/weaviate@v1.31.19
🐹Gogithub.com/weaviate/weaviate≥ 1.32.0-rc.0&&< 1.32.161.32.16go get github.com/weaviate/weaviate@v1.32.16
🐹Gogithub.com/weaviate/weaviate≥ 1.33.0-rc.0&&< 1.33.41.33.4go get github.com/weaviate/weaviate@v1.33.4

Affected Products

1 product · 1 configurations
Application
weaviateweaviate
< 1.33.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/weaviate/weaviate, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/weaviate/weaviate to 1.30.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-67818 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

An issue was discovered in Weaviate OSS before 1.33.4. An attacker with access to insert data into the database can craft an entry name with an absolute path (e.g., /etc/...) or use parent directory traversal (../../..) to escape the restore root when a backup is restored, potentially creating or overwriting files in arbitrary locations within the application's privilege scope.
O3 Security · Impact-Aware SCA

Is CVE-2025-67818 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2025-67818: weaviate — Fixed in 1.30.20