NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
LOW severity

CVE-2025-65014 — librenms

LOW

CVE-2025-65014 is a low-severity (CVSS 3.7) CWE-521 vulnerability in librenms/librenms. A fix is available for librenms/librenms — see the affected versions and patch details below.

LibreNMS has Weak Password Policy

Also known asGHSA-5mrf-j8v6-f45g
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-65014.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs20th percentile — riskier than 20% of all scored CVEsHighest risk
0.00%0.26%0.51%0.77%0.0%0.3%0.3%0.3%Jun 26Nov 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘librenms/librenms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Summary

A Weak Password Policy vulnerability was identified in the user management functionality of the LibreNMS application. This vulnerability allows administrators to create accounts with extremely weak and predictable passwords, such as 12345678. This exposes the platform to brute-force and credential stuffing attacks.


Details

Vulnerable Component: User creation / password definition

The application fails to enforce a strong password policy when creating new users. As a result, administrators can define trivial and well-known weak passwords, compromising the authentication security of the system.


PoC

  1. Log in to the application using an Administrator account.

  2. Navigate to the user management section:

  3. Create a new user account using the password 12345678.

<img width="1103" height="852" alt="image" src="https://github.com/user-attachments/assets/a20d4226-9f86-46ee-a4e6-45be91bb6b7b" />
  1. The application accepts the weak password without restrictions and creates the account successfully.
<img width="1359" height="487" alt="image" src="https://github.com/user-attachments/assets/9bec15bf-b38f-448b-8f98-acca5724e143" />

Impact

Weak password policy vulnerabilities can have severe consequences, including:

  • Increased risk of brute-force and credential stuffing attacks

  • Unauthorized access to user or administrative accounts

  • Privilege escalation through compromised credentials

  • Degradation of the overall security posture of the platform


Mitigation

  • Enforce a strong password policy (e.g., minimum of 12 characters with uppercase, lowercase, digits, and special characters).

  • Block the use of commonly known weak passwords (e.g., 12345678, password, admin, qwerty).

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistlibrenms/librenmsall versions25.11.0composer require librenms/librenms:^25.11.0

Affected Products

1 product · 1 configurations
Application
librenmslibrenms
< 25.11.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for librenms/librenms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update librenms/librenms to 25.11.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-65014 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

## Summary A **Weak Password Policy** vulnerability was identified in the user management functionality of the _LibreNMS_ application. This vulnerability allows administrators to create accounts with extremely weak and predictable passwords, such as `12345678`. This exposes the platform to brute-force and credential stuffing attacks. --- ## Details **Vulnerable Component:** User creation / password definition The application fails to enforce a strong password policy when creating new users. As a result, administrators can define trivial and well-known weak passwords, compromising the auth
O3 Security · Impact-Aware SCA

Is CVE-2025-65014 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2025-65014: librenms PrivEsc — Fixed in 25.11.0