CVE-2025-64758 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in @dependencytrack/frontend. A fix is available for @dependencytrack/frontend — see the affected versions and patch details below.
@dependencytrack/frontend Vulnerable to Persistent Cross-Site-Scripting via Welcome Message
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-64758.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@dependencytrack/frontendnpmDescription
Description
Since version 4.12.0, Dependency-Track users with the SYSTEM_CONFIGURATION permission can configure a "welcome message", which is HTML that is to be rendered on the login page for branding purposes.
When rendering the welcome message, Dependency-Track versions before 4.13.6 did not properly sanitize the HTML, allowing arbitrary JavaScript to be executed.
Impact
Users with the SYSTEM_CONFIGURATION permission (i.e., administrators), can exploit this weakness to execute arbitrary JavaScript for users browsing to the login page.
Patches
The issue has been fixed in version 4.13.6.
References
- The issue was introduced via: https://github.com/DependencyTrack/frontend/pull/986
- The issue was fixed via: https://github.com/DependencyTrack/frontend/pull/1378
Credit
Thanks to Jonas Benjamin Friedli for identifying and responsibly disclosing the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @dependencytrack/frontend | ≥ 4.12.0&&< 4.13.6 | 4.13.6npm install @dependencytrack/frontend@4.13.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @dependencytrack/frontend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @dependencytrack/frontend to 4.13.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-64758 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2025-64758 in your dependencies?
Find it across npm, including transitive dependencies.