NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹 Go
Not in CISA KEV

CVE-2025-64329 — containerd

Fix: containerd/containerd@083b53c

CVE-2025-64329 is a CWE-401 vulnerability in github.com/containerd/containerd. A fix is available for github.com/containerd/containerd — see the affected versions and patch details below.

containerd CRI server: Host memory exhaustion through Attach goroutine leak

Also known asGHSA-m6hq-p25p-ffr2GO-2025-4108
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-64329.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs6th percentile — riskier than 6% of all scored CVEsHighest risk
0.00%0.22%0.45%0.67%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

4 pkgs affected
🐹github.com/containerd/containerd🐹github.com/containerd/containerd/v2🐹github.com/containerd/containerd/v2🐹github.com/containerd/containerd/v2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

A bug was found in containerd's CRI Attach implementation where a user can exhaust memory on the host due to goroutine leaks.

Repetitive calls of CRI Attach (e.g., kubectl attach) could increase the memory usage of containerd.

Patches

This bug has been fixed in the following containerd versions:

  • 2.2.0
  • 2.1.5
  • 2.0.7
  • 1.7.29

Users should update to these versions to resolve the issue.

Workarounds

Set up an admission controller to control accesses to pods/attach resources. e.g., Validating Admission Policy.

Credits

The containerd project would like to thank @Wheat2018 for responsibly disclosing this issue in accordance with the containerd security policy.

References

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2025-64329

For more information

If you have any questions or comments about this advisory:

To report a security issue in containerd:

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/containerd/containerdall versions1.7.29go get github.com/containerd/containerd@v1.7.29
🐹Gogithub.com/containerd/containerd/v2all versions2.0.7go get github.com/containerd/containerd/v2@v2.0.7
🐹Gogithub.com/containerd/containerd/v2≥ 2.1.0-beta.0&&< 2.1.52.1.5go get github.com/containerd/containerd/v2@v2.1.5
🐹Gogithub.com/containerd/containerd/v2≥ 2.2.0-beta.0&&< 2.2.02.2.0go get github.com/containerd/containerd/v2@v2.2.0

Affected Products

1 product · 8 configurations
Application
containerdlinuxfoundation
≥ 2.1.0 && < 2.1.5
1 version
2.2.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/containerd/containerd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/containerd/containerd to 1.7.29 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-64329 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

The highest threat of this vulnerability is to system availability. A flaw in containerd's CRI Attach implementation allows a user to exhaust memory on the host due to goroutine leaks, leading to a denial of service.

Workaround published by Red Hat
To mitigate this vulnerability, set up an admission controller to control access to the pods/attach subresource. Restricting which users and service accounts can perform attach operations limits their ability to trigger the goroutine leak in containerd's CRI Attach implementation and exhaust memory on the host. Upstream has fixed this issue in containerd 1.7.29, 2.0.7, 2.1.5, and 2.2.0; apply updated containerd packages through the affected Red Hat product's update channels when available.
Source: Red Hat security advisory for CVE-2025-64329 (CC BY 4.0)
ProductFixed inAdvisory
Network Observability (NETOBSERV) 1.11.0network-observability/network-observability-cli-rhel9:1771226060RHSA-2026:2900
Red Hat Openshift Data Foundation 4.22odf4/cephcsi-rhel9:1782932114RHSA-2026:37387

Frequently Asked Questions

### Impact A bug was found in containerd's CRI Attach implementation where a user can exhaust memory on the host due to goroutine leaks. Repetitive calls of CRI Attach (e.g., [`kubectl attach`](https://kubernetes.io/docs/reference/kubectl/generated/kubectl_attach/)) could increase the memory usage of containerd. ### Patches This bug has been fixed in the following containerd versions: * 2.2.0 * 2.1.5 * 2.0.7 * 1.7.29 Users should update to these versions to resolve the issue. ### Workarounds Set up an admission controller to control accesses to `pods/attach` resources. e.g., [Validati
O3 Security · Impact-Aware SCA

Is CVE-2025-64329 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2025-64329: containerd — Fixed in 1.7.29