CVE-2025-64323 is a medium-severity (CVSS 5.3) CWE-862 vulnerability in github.com/kgateway-dev/kgateway/v2. A fix is available for github.com/kgateway-dev/kgateway/v2 — see the affected versions and patch details below.
kgateway is missing xDS authorization
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-64323.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/kgateway-dev/kgateway/v2🐹github.com/kgateway-dev/kgateway/v2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Summary
The xDS interface in Kgateway versions 2.0.0 through 2.0.4 lacks authentication, allowing any client with unrestricted network access to the xDS port to retrieve potentially sensitive configuration data including certificate data, backend service information, routing rules, and cluster metadata.
Description
Impact
Kgateway xDS interface did not have authorization, so anonymous clients with unrestricted network access could gain access to the xDS data. This could expose sensitive information about your gateway configuration, certificate data, backend services, and routing topology to unauthorized parties.
Patches
Upgrade to version 2.0.5 or 2.1.0. These versions enable JWT-based authentication for the xDS interface by default, ensuring that only authenticated clients can access the xDS configuration data.
Workarounds
If immediate upgrade is not possible, NetworkPolicies can be used to block access to kgateway's xDS port, restricting network access to only trusted sources.
References
- Fix in 2.1.0: https://github.com/kgateway-dev/kgateway/pull/12471
- Backport to 2.0.5: https://github.com/kgateway-dev/kgateway/pull/12535
- Related issue: https://github.com/kgateway-dev/kgateway/issues/10651
Credits
Kindly reported by @rikatz
For More Information
If you have any questions or comments about this advisory, please reach out in slack https://cloud-native.slack.com/archives/C080D3PJMS4
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/kgateway-dev/kgateway/v2 | ≥ 2.1.0-agw-cel-rbac&&< 2.1.0 | 2.1.0go get github.com/kgateway-dev/kgateway/v2@v2.1.0 |
| 🐹Go | github.com/kgateway-dev/kgateway/v2 | all versions | 2.0.5go get github.com/kgateway-dev/kgateway/v2@v2.0.5 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/kgateway-dev/kgateway/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/kgateway-dev/kgateway/v2 to 2.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-64323 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2025-64323 in your dependencies?
Find it across Go, including transitive dependencies.