CVE-2025-62820 is a medium-severity (CVSS 4.9) CWE-420 vulnerability in github.com/slackhq/nebula. A fix is available for github.com/slackhq/nebula — see the affected versions and patch details below.
Slack Nebula may accept arbitrary source IP addresses
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-62820.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/slackhq/nebulaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Slack Nebula before 1.9.7 mishandles CIDR in some configurations and thus accepts arbitrary source IP addresses within the Nebula network.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/slackhq/nebula | ≥ 1.9.4&&< 1.9.7 | 1.9.7go get github.com/slackhq/nebula@v1.9.7 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/slackhq/nebula, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/slackhq/nebula to 1.9.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-62820 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-62820 in your dependencies?
Find it across Go, including transitive dependencies.