NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2025-62371 — opensearch

HIGHFix: opensearch-project/data-prepper@98fcf0d

CVE-2025-62371 is a high-severity (CVSS 7.4) CWE-295 vulnerability in org.opensearch.dataprepper.plugins:opensearch. A fix is available for org.opensearch.dataprepper.plugins:opensearch — see the affected versions and patch details below.

OpenSearch Data Prepper plugins trusts all SSL certificates by default

Also known asGHSA-43ff-rr26-8hx4
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-62371.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs9th percentile — riskier than 9% of all scored CVEsHighest risk
0.00%0.23%0.46%0.70%0.0%0.2%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.opensearch.dataprepper.plugins:opensearch

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The OpenSearch sink and source plugins in Data Prepper are configured to trust all SSL certificates by default when no certificate path was provided, making connections vulnerable to man-in-the-middle attacks.

Prior to this fix, the OpenSearch sink and source plugins would automatically use a trust all SSL strategy when connecting to OpenSearch clusters if no certificate path was explicitly configured. This behavior bypassed SSL certificate validation, potentially allowing attackers to intercept and modify data in transit through man-in-the-middle attacks.

The vulnerability affects connections to OpenSearch when the cert parameter is not explicitly provided.

Patches

Data Prepper 2.12.2

Workarounds

If you cannot immediately upgrade to the fixed version, you can implement the following workaround.

OpenSearch sink

Add the cert parameter to your OpenSearch sink configuration with the path to your cluster's CA certificate. The following example shows how to accomplish this.

sink:
  - opensearch:
      hosts: ["https://your-opensearch-cluster:9200"]
      cert: /path/to/your/ca-certificate.pem

OpenSearch source

Add the cert parameter to your OpenSearch sink configuration with the path to your cluster's CA certificate. The following example shows how to accomplish this.

sink:
  - opensearch:
      hosts: ["https://your-opensearch-cluster:9200"]
      connection:
        cert: /path/to/your/ca-certificate.pem

References

N/A

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.opensearch.dataprepper.plugins:opensearchall versions2.12.2org.opensearch.dataprepper.plugins:opensearch:2.12.2

Affected Products

1 product · 1 configurations
Application
opensearch data prepperamazon
< 2.12.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opensearch.dataprepper.plugins:opensearch, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.opensearch.dataprepper.plugins:opensearch to 2.12.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-62371 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact The OpenSearch sink and source plugins in Data Prepper are configured to trust all SSL certificates by default when no certificate path was provided, making connections vulnerable to man-in-the-middle attacks. Prior to this fix, the OpenSearch sink and source plugins would automatically use a trust all SSL strategy when connecting to OpenSearch clusters if no certificate path was explicitly configured. This behavior bypassed SSL certificate validation, potentially allowing attackers to intercept and modify data in transit through man-in-the-middle attacks. The vulnerability affec
O3 Security · Impact-Aware SCA

Is CVE-2025-62371 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-62371: opensearch — Fixed in 2.12.2