NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2025-62237 — com.liferay.commerce.orde…

MEDIUMFix: liferay/liferay-portal@e6d49ed

CVE-2025-62237 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in com.liferay.commerce:com.liferay.commerce.order.web. A fix is available for com.liferay.commerce:com.liferay.commerce.order.web — see the affected versions and patch details below.

Liferay Portal Commerce is vulnerable to XSS through account "name" field

Also known asGHSA-m4g9-5mg6-gfr3
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-62237.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs13th percentile — riskier than 13% of all scored CVEsHighest risk
0.00%0.24%0.48%0.72%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.liferay.commerce:com.liferay.commerce.order.web

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Stored cross-site scripting (XSS) vulnerability in Commerce’s view order page in Liferay Portal 7.4.3.8 through 7.4.3.111, and Liferay DXP 2023.Q4.0 through 2023.Q4.5, 2023.Q3.1 through 2023.Q3.8, and 7.4 update 8 through update 92 allows remote attackers to inject arbitrary web script or HTML via a crafted payload injected into an Account’s “Name” text field.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.liferay.commerce:com.liferay.commerce.order.web≥ 5.0.29&&< 5.0.1015.0.101com.liferay.commerce:com.liferay.commerce.order.web:5.0.101

Affected Products

2 products · 89 configurations
Application
digital experience platformliferay
≥ 2023.q4.0 && < 2023.q4.6
1 version
7.4
Application
liferay portalliferay
≥ 7.4.3.8 && < 7.4.3.112
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay.commerce:com.liferay.commerce.order.web, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.liferay.commerce:com.liferay.commerce.order.web to 5.0.101 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-62237 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Stored cross-site scripting (XSS) vulnerability in Commerce’s view order page in Liferay Portal 7.4.3.8 through 7.4.3.111, and Liferay DXP 2023.Q4.0 through 2023.Q4.5, 2023.Q3.1 through 2023.Q3.8, and 7.4 update 8 through update 92 allows remote attackers to inject arbitrary web script or HTML via a crafted payload injected into an Account’s “Name” text field.
O3 Security · Impact-Aware SCA

Is CVE-2025-62237 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-62237: com.liferay.commerce — Fixed in 5.0.101