CVE-2025-61919 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in rack. A fix is available for rack — see the affected versions and patch details below.
Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-61919.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
rack💎rack💎rackReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Rack::Request#POST reads the entire request body into memory for Content-Type: application/x-www-form-urlencoded, calling rack.input.read(nil) without enforcing a length or cap. Large request bodies can therefore be buffered completely into process memory before parsing, leading to denial of service (DoS) through memory exhaustion.
Details
When handling non-multipart form submissions, Rack’s request parser performs:
form_vars = get_header(RACK_INPUT).read
Since read is called with no argument, the entire request body is loaded into a Ruby String. This occurs before query parameter parsing or enforcement of any params_limit. As a result, Rack applications without an upstream body-size limit can experience unbounded memory allocation proportional to request size.
Impact
Attackers can send large application/x-www-form-urlencoded bodies to consume process memory, causing slowdowns or termination by the operating system (OOM). The effect scales linearly with request size and concurrency. Even with parsing limits configured, the issue occurs before those limits are enforced.
Mitigation
- Update to a patched version of Rack that enforces form parameter limits using
query_parser.bytesize_limit, preventing unbounded reads ofapplication/x-www-form-urlencodedbodies. - Enforce strict maximum body size at the proxy or web server layer (e.g., Nginx
client_max_body_size, ApacheLimitRequestBody).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | rack | all versions | 2.2.20bundle update rack --conservative |
| 💎RubyGems | rack | ≥ 3.0&&< 3.1.18 | 3.1.18bundle update rack --conservative |
| 💎RubyGems | rack | ≥ 3.2&&< 3.2.3 | 3.2.3bundle update rack --conservative |
Affected Products
rackrackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rack, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update rack to 2.2.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-61919 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
~~~ Affectedness: Rack 1.x, including 1.6.x, is not affected by this vulnerability. The issue exists only in Rack 2.x and 3.x, where request parsing was refactored into the QueryParser component. Since Rack 1.x does not include this component, it does not contain the vulnerable logic. Ruby 2.x and 3.x versions shipped…
No mitigation is currently available that meets Red Hat Product Security's standards for usability, deployment, applicability, or stability beyond these configuration-based workarounds.Source: Red Hat security advisory for CVE-2025-61919 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | pcs-0:0.12.0-3.el10_0.3 | RHSA-2025:19513 |
| Red Hat Enterprise Linux 10 | pcs-0:0.12.1-1.el10_1.1 | RHSA-2025:21036 |
| Red Hat Enterprise Linux 7 Extended Lifecycle Support | pcs-0:0.9.169-3.el7_9.5 | RHSA-2025:21696 |
| Red Hat Enterprise Linux 8 | pcs-0:0.10.18-2.el8_10.7 | RHSA-2025:19719 |
| Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support | pcs-0:0.10.8-1.el8_4.8 | RHSA-2025:19948 |
| Red Hat Enterprise Linux 8.6 Telecommunications Update Service | pcs-0:0.10.12-6.el8_6.10 | RHSA-2025:19734 |
| Red Hat Enterprise Linux 8.8 Telecommunications Update Service | pcs-0:0.10.15-4.el8_8.9 | RHSA-2025:19647 |
| Red Hat Enterprise Linux 9 | pcs-0:0.11.9-2.el9_6.2 | RHSA-2025:19512 |
Frequently Asked Questions
Is CVE-2025-61919 in your dependencies?
Find it across RubyGems, including transitive dependencies.