CVE-2025-61772 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in rack. A fix is available for rack — see the affected versions and patch details below.
Rack's multipart parser buffers unbounded per-part headers, enabling DoS (memory exhaustion)
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-61772.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
rack💎rack💎rackReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Rack::Multipart::Parser can accumulate unbounded data when a multipart part’s header block never terminates with the required blank line (CRLFCRLF). The parser keeps appending incoming bytes to memory without a size cap, allowing a remote attacker to exhaust memory and cause a denial of service (DoS).
Details
While reading multipart headers, the parser waits for CRLFCRLF using:
@sbuf.scan_until(/(.*?\r\n)\r\n/m)
If the terminator never appears, it continues appending data (@sbuf.concat(content)) indefinitely. There is no limit on accumulated header bytes, so a single malformed part can consume memory proportional to the request body size.
Impact
Attackers can send incomplete multipart headers to trigger high memory use, leading to process termination (OOM) or severe slowdown. The effect scales with request size limits and concurrency. All applications handling multipart uploads may be affected.
Mitigation
- Upgrade to a patched Rack version that caps per-part header size (e.g., 64 KiB).
- Until then, restrict maximum request sizes at the proxy or web server layer (e.g., Nginx
client_max_body_size).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | rack | all versions | 2.2.19bundle update rack --conservative |
| 💎RubyGems | rack | ≥ 3.1&&< 3.1.17 | 3.1.17bundle update rack --conservative |
| 💎RubyGems | rack | ≥ 3.2&&< 3.2.2 | 3.2.2bundle update rack --conservative |
Affected Products
rackrackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rack, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update rack to 2.2.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-61772 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The availability risk to Red Hat systems is limited to the application which has integrated rack. The host operating system availability is not at risk.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2025-61772 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | pcs-0:0.12.0-3.el10_0.3 | RHSA-2025:19513 |
| Red Hat Enterprise Linux 10 | pcs-0:0.12.1-1.el10_1.1 | RHSA-2025:21036 |
| Red Hat Enterprise Linux 8 | pcs-0:0.10.18-2.el8_10.7 | RHSA-2025:19719 |
| Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support | pcs-0:0.10.8-1.el8_4.8 | RHSA-2025:19948 |
| Red Hat Enterprise Linux 8.6 Telecommunications Update Service | pcs-0:0.10.12-6.el8_6.10 | RHSA-2025:19734 |
| Red Hat Enterprise Linux 8.8 Telecommunications Update Service | pcs-0:0.10.15-4.el8_8.9 | RHSA-2025:19647 |
| Red Hat Enterprise Linux 9 | pcs-0:0.11.9-2.el9_6.2 | RHSA-2025:19512 |
| Red Hat Enterprise Linux 9 | pcs-0:0.11.10-1.el9_7.1 | RHSA-2025:20962 |
Frequently Asked Questions
Is CVE-2025-61772 in your dependencies?
Find it across RubyGems, including transitive dependencies.