CVE-2025-6176 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in brotli. A fix is available for brotli — see the affected versions and patch details below.
Scrapy is vulnerable to a denial of service (DoS) attack due to flaws in brotli decompression implementation
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-6176.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
brotli🐍scrapyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Scrapy versions up to 2.13.3 are vulnerable to a denial of service (DoS) attack due to a flaw in its brotli decompression implementation. The protection mechanism against decompression bombs fails to mitigate the brotli variant, allowing remote servers to crash clients with less than 80GB of available memory. This occurs because brotli can achieve extremely high compression ratios for zero-filled data, leading to excessive memory consumption during decompression. Mitigation for this vulnerability needs security enhancement added in brotli v1.2.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | brotli | all versions | 1.2.0pip install --upgrade 'brotli==1.2.0' |
| 🐍PyPI | scrapy | all versions | 2.13.4pip install --upgrade 'scrapy==2.13.4' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for brotli, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update brotli to 1.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-6176 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated Important for Red Hat products. The flaw in Scrapy's brotli decompression implementation allows remote attackers to trigger a denial of service by sending specially crafted brotli-compressed data. This can lead to excessive memory consumption and system instability.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2025-6176 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | brotli-0:1.1.0-7.el10_1 | RHSA-2026:0845 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | brotli-0:1.1.0-6.el10_0.1 | RHSA-2026:0008 |
| Red Hat Enterprise Linux 8 | brotli-0:1.0.6-4.el8_10 | RHSA-2026:2389 |
| Red Hat Enterprise Linux 8.2 Advanced Update Support | brotli-0:1.0.6-1.el8_2.1 | RHSA-2026:2401 |
| Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support | brotli-0:1.0.6-4.el8_4 | RHSA-2026:2399 |
| Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support | brotli-0:1.0.6-4.el8_6 | RHSA-2026:2455 |
| Red Hat Enterprise Linux 8.8 Telecommunications Update Service | brotli-0:1.0.6-4.el8_8 | RHSA-2026:2400 |
| Red Hat Enterprise Linux 9 | brotli-0:1.0.9-9.el9_7 | RHSA-2026:2042 |
Frequently Asked Questions
Is CVE-2025-6176 in your dependencies?
Find it across PyPI, including transitive dependencies.