NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io.NET NuGet🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2020-8927 — compu-brotli-sys

MEDIUMFix: google/brotli@223d80c

CVE-2020-8927 is a medium-severity (CVSS 6.5) CWE-130 vulnerability in compu-brotli-sys. A fix is available for compu-brotli-sys — see the affected versions and patch details below.

Integer overflow in the bundled Brotli C library

Also known asBIT-brotli-2020-8927BIT-dotnet-2020-8927BIT-dotnet-sdk-2020-8927BIT-powershell-2020-8927CVE-2020-36846GHSA-5v8v-66v8-mwm7
Published
Updated
Affected
149 pkgs
Patched
149 / 149
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2020-8927.

EPSS Exploitation Probability

via FIRST.org ↗
3.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
0.00%1.36%2.73%4.09%0.3%3.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

149 pkgs affected
🦀compu-brotli-sys.NETMicrosoft.NETCore.App.Runtime.linux-arm.NETMicrosoft.NETCore.App.Runtime.linux-arm64.NETMicrosoft.NETCore.App.Runtime.linux-musl-arm64.NETMicrosoft.NETCore.App.Runtime.linux-x64.NETMicrosoft.NETCore.App.Runtime.osx-x64.NETMicrosoft.NETCore.App.Runtime.win-arm.NETMicrosoft.NETCore.App.Runtime.win-arm64+141 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io, NuGet packages — download data is not available via public APIs for these ecosystems.

Description

A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.

Affected Packages

149 total 149 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iocompu-brotli-sysall versions1.0.9cargo update -p compu-brotli-sys --precise 1.0.9
.NETNuGetMicrosoft.NETCore.App.Runtime.linux-arm≥ 3.0.0&&< 3.1.233.1.23dotnet add package Microsoft.NETCore.App.Runtime.linux-arm --version 3.1.23
.NETNuGetMicrosoft.NETCore.App.Runtime.linux-arm64≥ 3.0.0&&< 3.1.233.1.23dotnet add package Microsoft.NETCore.App.Runtime.linux-arm64 --version 3.1.23
.NETNuGetMicrosoft.NETCore.App.Runtime.linux-musl-arm64≥ 3.0.0&&< 3.1.233.1.23dotnet add package Microsoft.NETCore.App.Runtime.linux-musl-arm64 --version 3.1.23
.NETNuGetMicrosoft.NETCore.App.Runtime.linux-x64≥ 3.0.0&&< 3.1.233.1.23dotnet add package Microsoft.NETCore.App.Runtime.linux-x64 --version 3.1.23
.NETNuGetMicrosoft.NETCore.App.Runtime.osx-x64≥ 3.0.0&&< 3.1.233.1.23dotnet add package Microsoft.NETCore.App.Runtime.osx-x64 --version 3.1.23

Affected Products

10 products · 21 configurations
OS
ubuntu linuxcanonical
3 versions
16.0418.0420.04
OS
debian linuxdebian
2 versions
9.010.0
OS
fedorafedoraproject
6 versions
313233343536
Application
brotligoogle
< 1.0.8
range
Application
.netmicrosoft
≥ 5.0 && ≤ 5.0.14
range
Application
.net coremicrosoft
≥ 3.1 && ≤ 3.1.22
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for compu-brotli-sys, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update compu-brotli-sys to 1.0.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-8927 is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
Workaround published by Red Hat
This flaw can be mitigated by using Streaming API instead of the One-Shot API and imposing chunk size limitations.
Source: Red Hat security advisory for CVE-2020-8927 (CC BY 4.0)
ProductFixed inAdvisory
.NET Core on Red Hat Enterprise Linuxrh-dotnet31-dotnet-0:3.1.417-1.el7_9RHSA-2022:0829
.NET Core on Red Hat Enterprise Linuxrh-dotnet50-dotnet-0:5.0.212-1.el7_9RHSA-2022:0828
Red Hat Enterprise Linux 8brotli-0:1.0.6-3.el8RHSA-2021:1702
Red Hat Enterprise Linux 8dotnet3.1-0:3.1.417-1.el8_5RHSA-2022:0827
Red Hat Enterprise Linux 8dotnet5.0-0:5.0.212-1.el8_5RHSA-2022:0830

Frequently Asked Questions

A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.
O3 Security · Impact-Aware SCA

Is CVE-2020-8927 in your dependencies?

Find it across crates.io, NuGet, PyPI, including transitive dependencies.

CVE-2020-8927: compu-brotli — Fixed in 1.0.9