CVE-2025-61140 — jsonpath
Fix: dchester/jsonpath#195CVE-2025-61140 is a CWE-1321 vulnerability in jsonpath. A fix is available for jsonpath — see the affected versions and patch details below.
JSONPath vulnerable to Prototype Pollution due to insufficient input validation of object keys in lib/index.js
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-61140.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
jsonpathnpmDescription
The value function in jsonpath 1.1.1 lib/index.js is vulnerable to Prototype Pollution.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | jsonpath | all versions | 1.2.0npm install jsonpath@1.2.0 |
Affected Products
jsonpathdchesterDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for jsonpath, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update jsonpath to 1.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-61140 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.1 | ansible-automation-platform/automation-portal:1770282458 | RHSA-2026:2181 |
| Red Hat Ansible Automation Platform 2.5 | ansible-automation-platform-25/lightspeed-rhel8:1772214630 | RHSA-2026:3962 |
| Red Hat Ansible Automation Platform 2.6 | ansible-automation-platform-26/lightspeed-rhel9:1772552788 | RHSA-2026:3960 |
| Red Hat Developer Hub 1.8 | rhdh/rhdh-hub-rhel9:1774545605 | RHSA-2026:6174 |
| Red Hat Developer Hub 1.9 | rhdh/rhdh-hub-rhel9:1775140647 | RHSA-2026:6802 |
| Self-service automation portal 2.0 | ansible-automation-platform/automation-portal:1770281704 | RHSA-2026:2180 |
Frequently Asked Questions
Is CVE-2025-61140 in your dependencies?
Find it across npm, including transitive dependencies.