CVE-2025-57738 is a high-severity (CVSS 7.2) CWE-653 vulnerability in org.apache.syncope.core:syncope-core-spring. EPSS puts its 30-day exploitation probability at 23.2% (98th percentile). A fix is available for org.apache.syncope.core:syncope-core-spring — see the affected versions and patch details below.
Apache Syncope: Remote Code Execution by delegated administrators
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-57738.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.syncope.core:syncope-core-spring☕org.apache.syncope.core:syncope-core-springReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Syncope offers the ability to extend / customize the base behavior on every deployment by allowing to provide custom implementations of a few Java interfaces; such implementations can be provided either as Java or Groovy classes, with the latter being particularly attractive as the machinery is set for runtime reload. Such a feature has been available for a while, but recently it was discovered that a malicious administrator can inject Groovy code that can be executed remotely by a running Apache Syncope Core instance. Users are recommended to upgrade to version 3.0.14 / 4.0.2, which fix this issue by forcing the Groovy code to run in a sandbox.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.syncope.core:syncope-core-spring | all versions | 3.0.14org.apache.syncope.core:syncope-core-spring:3.0.14 |
| ☕Maven | org.apache.syncope.core:syncope-core-spring | ≥ 4.0.0-M0&&< 4.0.2 | 4.0.2org.apache.syncope.core:syncope-core-spring:4.0.2 |
Affected Products
syncopeapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.syncope.core:syncope-core-spring, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.syncope.core:syncope-core-spring to 3.0.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-57738 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-57738 in your dependencies?
Find it across Maven, including transitive dependencies.