CVE-2025-54433 — bugsink
Fix: bugsink/bugsink@1001726CVE-2025-54433 is a Path Traversal vulnerability in bugsink. A fix is available for bugsink — see the affected versions and patch details below.
Bugsink is vulnerable to Path Traversal attacks via event_id in ingestion
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-54433.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
bugsink🐍bugsink🐍bugsink🐍bugsinkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Summary
In affected versions, ingestion paths construct file locations directly from untrusted event_id input without validation. A specially crafted event_id can result in paths outside the intended directory, potentially allowing file overwrite or creation in arbitrary locations.
Submitting such input requires access to a valid DSN. While that limits exposure, DSNs are sometimes discoverable—for example, when included in frontend code—and should not be treated as a strong security boundary.
Impact
A valid DSN holder can craft an event_id that causes the ingestion process to write files outside its designated directory. This allows overwriting files accessible to the user running Bugsink.
If Bugsink runs in a container, the effect is confined to the container’s filesystem. In non-containerized setups, the overwrite may affect other parts of the system accessible to that user.
Mitigation
Update to version 1.7.4, 1.6.4, 1.5.5 or 1.4.3 , which require event_id to be a valid UUID and normalizes it before use in file paths.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | bugsink | ≥ 1.7.0&&< 1.7.4 | 1.7.4pip install --upgrade 'bugsink==1.7.4' |
| 🐍PyPI | bugsink | ≥ 1.6.0&&< 1.6.4 | 1.6.4pip install --upgrade 'bugsink==1.6.4' |
| 🐍PyPI | bugsink | ≥ 1.5.0&&< 1.5.5 | 1.5.5pip install --upgrade 'bugsink==1.5.5' |
| 🐍PyPI | bugsink | all versions | 1.4.3pip install --upgrade 'bugsink==1.4.3' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bugsink, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update bugsink to 1.7.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-54433 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2025-54433 in your dependencies?
Find it across PyPI, including transitive dependencies.