CVE-2025-54313 is a high-severity (CVSS 7.5) CWE-506 vulnerability in eslint-config-prettier. It is in CISA's Known Exploited Vulnerabilities catalog (added 2026-01-22) — treat it as actively exploited and patch now. A fix is available for eslint-config-prettier — see the affected versions and patch details below.
eslint-config-prettier, eslint-plugin-prettier, synckit, @pkgr/core, napi-postinstall have embedded malicious code
Exploitation Status
Actively exploited in the wild
- Confirmed by CISA's Known Exploited Vulnerabilities catalog on 2026-01-22. Federal agencies were required to remediate by 2026-02-12.
Exploitation and automatability from CISA (KEV catalog and SSVC triage) for CVE-2025-54313.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
CVE-2025-54313 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.
Where this sits among everything scored
Of 396,257 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
eslint-config-prettiernpmDescription
eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise. Installing an affected package executes an install.js file that launches the node-gyp.dll malware on Windows.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | eslint-config-prettier | ≥ 8.10.1&&< 8.10.2 | 8.10.2npm install eslint-config-prettier@8.10.2 |
| 📦npm | eslint-config-prettier | ≥ 9.1.1&&< 9.1.2 | 9.1.2npm install eslint-config-prettier@9.1.2 |
| 📦npm | eslint-config-prettier | ≥ 10.1.6&&< 10.1.8 | 10.1.8npm install eslint-config-prettier@10.1.8 |
| 📦npm | eslint-plugin-prettier | ≥ 4.2.2&&< 4.2.4 | 4.2.4npm install eslint-plugin-prettier@4.2.4 |
| 📦npm | synckit | ≥ 0.11.9&&< 0.11.10 | 0.11.10npm install synckit@0.11.10 |
| 📦npm | @pkgr/core | ≥ 0.2.8&&< 0.2.9 | 0.2.9npm install @pkgr/core@0.2.9 |
Affected Products
got-fetchalexghrhomarrhomarreslint-config-prettierprettiereslint-plugin-prettierprettiernapi-postinstallun-tspkgr\/coreun-tsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for eslint-config-prettier, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update eslint-config-prettier to 8.10.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-54313 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
No affected versions of eslint-config-prettier are shipped in any Red Hat products.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2025-54313 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2025-54313 in your dependencies?
Find it across npm, including transitive dependencies.