NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2025-54128 — @haxtheweb/haxcms-nodejs

Fix: haxtheweb/haxcms-nodejs@ddb9351

CVE-2025-54128 is a Cross-site Scripting (XSS) vulnerability in @haxtheweb/haxcms-nodejs. A fix is available for @haxtheweb/haxcms-nodejs — see the affected versions and patch details below.

HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting

Also known asGHSA-59g8-h59f-8hjp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-54128.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs14th percentile — riskier than 14% of all scored CVEsHighest risk
0.00%0.24%0.49%0.73%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@haxtheweb/haxcms-nodejsnpm
1Kdownloads / week

Description

Summary

The NodeJS version of HAX CMS has a disabled Content Security Policy (CSP). This configuration is insecure for a production application because it does not protect against cross-site-scripting attacks.

Details

The contentSecurityPolicy value is explicitly disabled in the application's Helmet configuration in app.js.

permissive-csp-code

Affected Resources

PoC

To reproduce this vulnerability, install HAX CMS NodeJS. The application will load without a CSP configured.

Impact

In conjunction with an XSS vulnerability, an attacker could execute arbitrary scripts and exfiltrate data, including session tokens and sensitive local data.

Additional Information

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@haxtheweb/haxcms-nodejsall versions11.0.8npm install @haxtheweb/haxcms-nodejs@11.0.8

Affected Products

1 product · 1 configurations
Application
haxcms-nodejspsu
< 11.0.8
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @haxtheweb/haxcms-nodejs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @haxtheweb/haxcms-nodejs to 11.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-54128 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Summary The NodeJS version of HAX CMS has a disabled Content Security Policy (CSP). This configuration is insecure for a production application because it does not protect against cross-site-scripting attacks. ### Details The `contentSecurityPolicy` value is explicitly disabled in the application's Helmet configuration in `app.js`. ![permissive-csp-code](https://github.com/user-attachments/assets/8ec6c63c-9f9f-413e-be7e-ed14913da91c) #### Affected Resources - [app.js:52](https://github.com/haxtheweb/haxcms-nodejs/blob/b1f95880b42fea6ed07855b5804b29b182ec5e07/src/app.js#L52) ### PoC To
O3 Security · Impact-Aware SCA

Is CVE-2025-54128 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2025-54128: @haxtheweb/haxcms — Fixed in 11.0.8