CVE-2025-52893 is a medium-severity (CVSS 4.5) CWE-532 vulnerability in github.com/openbao/openbao/sdk/v2. A fix is available for github.com/openbao/openbao/sdk/v2 — see the affected versions and patch details below.
OpenBao May Leak Sensitive Information in Logs When Processing Malformed Data
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-52893.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/openbao/openbao/sdk/v2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
OpenBao before v2.3.0 and HashiCorp Vault as of the current v1.19.5 may leak sensitive information in logs when processing malformed data. This is separate from the earlier HCSEC-2025-09 / CVE-2025-4166.
Patches
This issue has been fixed in OpenBao v2.3.0 and later.
Workarounds
Like with HCSEC-2025-09, there is no known workaround except to ensure properly formatted requests from all clients.
Remediation
Users with the capability to search through server and audit logs for any possible exposed secrets can refer to the following snippets to aid in searching:
Audit Log
... "error":"error converting input for field \"password\": expected type 'string', got unconvertible type 'map[string]interface {}', value: '<sensitive data>'" ...
Server Log
error converting input for field "password": expected type 'string', got unconvertible type 'map[string]interface {}', value: '<sensitive data>'
If any matches are found, rotating the affected secret is advised.
References
See also: https://github.com/go-viper/mapstructure/releases/tag/v2.3.0
See also: https://github.com/go-viper/mapstructure/pull/105 -> https://github.com/go-viper/mapstructure/commit/ed3f92181528ff776a0324107b8b55026e93766a
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/openbao/openbao/sdk/v2 | all versions | 2.3.0go get github.com/openbao/openbao/sdk/v2@v2.3.0 |
Affected Products
openbaoopenbaoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/openbao/openbao/sdk/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/openbao/openbao/sdk/v2 to 2.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-52893 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-52893 in your dependencies?
Find it across Go, including transitive dependencies.