CVE-2025-49581 — xwiki-platform-rendering-…
Fix: xwiki/xwiki-platform@c99d501CVE-2025-49581 is a Code Injection vulnerability in org.xwiki.platform:xwiki-platform-rendering-wikimacro-store. A fix is available for org.xwiki.platform:xwiki-platform-rendering-wikimacro-store — see the affected versions and patch details below.
XWiki allows remote code execution through default value of wiki macro wiki-type parameters
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-49581.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.xwiki.platform:xwiki-platform-rendering-wikimacro-store☕org.xwiki.platform:xwiki-platform-rendering-wikimacro-store☕org.xwiki.platform:xwiki-platform-rendering-wikimacro-store☕org.xwiki.platform:xwiki-platform-rendering-wikimacro-store☕org.xwiki.platform:xwiki-platform-rendering-wikimacro-storeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Any user with edit right on a page (could be the user's profile) can execute code (Groovy, Python, Velocity) with programming right by defining a wiki macro. This allows full access to the whole XWiki installation and thus impacts its confidentiality, integrity and availability. The main problem is that if a wiki macro parameter allows wiki syntax, its default value is executed with the rights of the author of the document where it is used. This can be exploited by overriding a macro like the children macro that is used in a page that has programming right like the page XWiki.ChildrenMacro and thus allows arbitrary script macros. The full reproduction steps can be found in the original issue.
Patches
This vulnerability has been patched in XWiki 16.4.7, 16.10.3 and 17.0.0 by executing wiki parameters with the rights of the wiki macro's author when the parameter's value is the default value.
Workarounds
We're not aware of any workarounds except for upgrading.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-rendering-wikimacro-store | ≥ 11.10.11 | No fix |
| ☕Maven | org.xwiki.platform:xwiki-platform-rendering-wikimacro-store | ≥ 12.6.3 | No fix |
| ☕Maven | org.xwiki.platform:xwiki-platform-rendering-wikimacro-store | ≥ 12.8-rc-1&&< 16.4.7 | 16.4.7org.xwiki.platform:xwiki-platform-rendering-wikimacro-store:16.4.7 |
| ☕Maven | org.xwiki.platform:xwiki-platform-rendering-wikimacro-store | ≥ 16.5.0-rc-1&&< 16.10.3 | 16.10.3org.xwiki.platform:xwiki-platform-rendering-wikimacro-store:16.10.3 |
| ☕Maven | org.xwiki.platform:xwiki-platform-rendering-wikimacro-store | ≥ 17.0.0-rc-1&&< 17.0.0 | 17.0.0org.xwiki.platform:xwiki-platform-rendering-wikimacro-store:17.0.0 |
Affected Products
xwikixwikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-rendering-wikimacro-store, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
A fix is available for CVE-2025-49581; check the affected-versions list above or the advisory for the patched release of org.xwiki.platform:xwiki-platform-rendering-wikimacro-store, then make sure no transitive dependency still pins the vulnerable range.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2025-49581 in your dependencies?
Find it across Maven, including transitive dependencies.