CVE-2021-21379 — xwiki-platform-rendering-…
MEDIUMCVE-2021-21379 is a medium-severity (CVSS 5.4) CWE-281 vulnerability in org.xwiki.platform:xwiki-platform-rendering-wikimacro-store. A fix is available for org.xwiki.platform:xwiki-platform-rendering-wikimacro-store — see the affected versions and patch details below.
It's possible to execute anything with the rights of the author of a macro which uses the {{wikimacrocontent}} macro
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-rendering-wikimacro-store☕org.xwiki.platform:xwiki-platform-rendering-wikimacro-store☕org.xwiki.platform:xwiki-platform-rendering-wikimacro-storeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The {{wikimacrocontent}} executes the content with the rights of the wiki macro author instead of the caller of that wiki macro. This makes possible to inject scripts through it and they will be executed with the rights of the wiki macro (very often a user which has Programming rights).
Fortunately, no such macro exists by default in XWiki Standard but one could have been created or installed with an extension.
Patches
It has been patched in versions XWiki 12.6.3, 11.10.11 and 12.8-rc-1.
Workarounds
There is no easy workaround other than disabling the affected macros. Inserting content in a safe way or knowing what is the user who called the wiki macro is not easy.
References
https://jira.xwiki.org/browse/XWIKI-17759
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira XWiki
- Email us at our security mailing list
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-rendering-wikimacro-store | ≥ 11.4&&< 11.10.11 | 11.10.11org.xwiki.platform:xwiki-platform-rendering-wikimacro-store:11.10.11 |
| ☕Maven | org.xwiki.platform:xwiki-platform-rendering-wikimacro-store | ≥ 12.0&&< 12.6.3 | 12.6.3org.xwiki.platform:xwiki-platform-rendering-wikimacro-store:12.6.3 |
| ☕Maven | org.xwiki.platform:xwiki-platform-rendering-wikimacro-store | ≥ 12.7&&< 12.8 | 12.8org.xwiki.platform:xwiki-platform-rendering-wikimacro-store:12.8 |
Affected Products
xwikixwikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-rendering-wikimacro-store, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-rendering-wikimacro-store to 11.10.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-21379 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2021-21379 in your dependencies?
Find it across Maven, including transitive dependencies.