NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET NuGet
Not in CISA KEV

CVE-2025-48378 — DotNetNuke.Core

Fix: dnnsoftware/Dnn.Platform@cfed83c

CVE-2025-48378 is a Cross-site Scripting (XSS) vulnerability in DotNetNuke.Core. A fix is available for DotNetNuke.Core — see the affected versions and patch details below.

Dnn.Platform vulnerable to Stored Cross-Site Scripting (XSS) with svg files rendered inline

Also known asGHSA-m4hf-fxcg-cp34
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-48378.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs22th percentile — riskier than 22% of all scored CVEsHighest risk
0.00%0.27%0.53%0.80%0.1%0.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
.NETDotNetNuke.Core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to version 9.13.9, uploaded SVG files could contain scripts and if rendered inline those scripts could run allowing XSS attacks. Version 9.13.9 fixes the issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetDotNetNuke.Coreall versions9.13.9dotnet add package DotNetNuke.Core --version 9.13.9

Affected Products

1 product · 1 configurations
Application
dotnetnukednnsoftware
< 9.13.9
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for DotNetNuke.Core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update DotNetNuke.Core to 9.13.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-48378 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to version 9.13.9, uploaded SVG files could contain scripts and if rendered inline those scripts could run allowing XSS attacks. Version 9.13.9 fixes the issue.
O3 Security · Impact-Aware SCA

Is CVE-2025-48378 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2025-48378: DotNetNuke.Core XSS — Fixed in 9.13.9