NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2025-45691 — ragas

HIGHFix: explodinggradients/ragas#1559

CVE-2025-45691 is a high-severity (CVSS 7.5) Path Traversal vulnerability in ragas. A fix is available for ragas — see the affected versions and patch details below.

RAGAS has an Arbitrary File Read vulnerability

Also known asGHSA-v2xr-wvrv-p969PYSEC-2026-3047
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-45691.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs49th percentile — riskier than 49% of all scored CVEsHighest risk
0.00%0.37%0.74%1.11%0.0%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍ragas

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An Arbitrary File Read vulnerability exists in the ImageTextPromptValue class in Exploding Gradients RAGAS v0.2.3 to v0.2.14. The vulnerability stems from improper validation and sanitization of URLs supplied in the retrieved_contexts parameter when handling multimodal inputs.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIragas≥ 0.2.3&&< 0.3.0-rc10.3.0-rc1pip install --upgrade 'ragas==0.3.0-rc1'

Affected Products

1 product · 1 configurations
Application
ragasvibrantlabsai
≥ 0.2.3 && ≤ 0.2.14
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ragas, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ragas to 0.3.0-rc1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-45691 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

To exploit this flaw, an attacker needs to supply malicious input to a Ragas evaluation pipeline, typically by poisoning a dataset or submitting payloads directly via an API. This issue allows arbitrary file reads, internal port scans and access to cloud metadata, but it does not cause memory corruption or arbitrary…

Workaround published by Red Hat
To mitigate this vulnerability, implement strict input validation to filter out malicious payloads before passing the retrieved_contexts parameter to the Ragas evaluation pipeline. Specifically, enforce an allowlist that only accepts http:// or https:// URLs, explicitly rejecting the file:// scheme. Additionally, ensure the account running the Ragas process operates with principle of least privilege, restricting access to sensitive system files.
Source: Red Hat security advisory for CVE-2025-45691 (CC BY 4.0)

Frequently Asked Questions

An Arbitrary File Read vulnerability exists in the ImageTextPromptValue class in Exploding Gradients RAGAS v0.2.3 to v0.2.14. The vulnerability stems from improper validation and sanitization of URLs supplied in the retrieved_contexts parameter when handling multimodal inputs.
O3 Security · Impact-Aware SCA

Is CVE-2025-45691 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2025-45691: ragas — Fixed in 0.3.0-rc1