NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2025-43800 — com.liferay.dynamic.data.…

MEDIUM

CVE-2025-43800 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in com.liferay:com.liferay.dynamic.data.mapping.form.field.type. A fix is available for com.liferay:com.liferay.dynamic.data.mapping.form.field.type — see the affected versions and patch details below.

Liferay Portal Cross-site Scripting (XSS) vulnerability

Also known asGHSA-jfv5-r382-xvwh
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-43800.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs14th percentile — riskier than 14% of all scored CVEsHighest risk
0.00%0.24%0.48%0.73%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.liferay:com.liferay.dynamic.data.mapping.form.field.type

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in Objects in Liferay Portal 7.4.3.20 through 7.4.3.111, and Liferay DXP 2023.Q4.0, 2023.Q3.1 through 2023.Q3.4 and 7.4 GA through update 92 allows remote attackers to inject arbitrary web script or HTML via a crafted payload injected into an object with a rich text type field.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.liferay:com.liferay.dynamic.data.mapping.form.field.typeall versions6.0.167com.liferay:com.liferay.dynamic.data.mapping.form.field.type:6.0.167

Affected Products

2 products · 4 configurations
Application
digital experience platformliferay
≥ 2023.q3.1 && < 2023.q3.5
2 versions
7.42023.q4.0
Application
liferay portalliferay
≥ 7.4.3.20 && < 7.4.3.112
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay:com.liferay.dynamic.data.mapping.form.field.type, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.liferay:com.liferay.dynamic.data.mapping.form.field.type to 6.0.167 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-43800 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in Objects in Liferay Portal 7.4.3.20 through 7.4.3.111, and Liferay DXP 2023.Q4.0, 2023.Q3.1 through 2023.Q3.4 and 7.4 GA through update 92 allows remote attackers to inject arbitrary web script or HTML via a crafted payload injected into an object with a rich text type field.
O3 Security · Impact-Aware SCA

Is CVE-2025-43800 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-43800: XSS — Fixed in 6.0.167