CVE-2025-32951 is a medium-severity (CVSS 6.4) Cross-site Scripting (XSS) vulnerability in io.jmix.rest:jmix-rest. A fix is available for io.jmix.rest:jmix-rest — see the affected versions and patch details below.
io.jmix.rest:jmix-rest allows XSS in the /files Endpoint of the Generic REST API
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-32951.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.jmix.rest:jmix-rest☕io.jmix.rest:jmix-restReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The input parameter, which consists of a file path and name, can be manipulated to return the Content-Type header with text/html if the name part ends with .html. This could allow malicious JavaScript code to be executed in the browser. For a successful attack, a malicious file needs to be uploaded beforehand.
The severity of the vulnerability is mitigated by the fact that the application UI and the generic REST API are typically accessible only to authenticated users. Additionally, the /files endpoint in Jmix requires specific permissions and is disabled by default.
Patches
The problem has been fixed in Jmix 1.6.2+ and 2.4.0+.
Workarounds
A workaround for those who are unable to upgrade: Disable Files Endpoint in Jmix Application.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.jmix.rest:jmix-rest | ≥ 1.0.0&&< 1.6.2 | 1.6.2io.jmix.rest:jmix-rest:1.6.2 |
| ☕Maven | io.jmix.rest:jmix-rest | ≥ 2.0.0&&< 2.4.0 | 2.4.0io.jmix.rest:jmix-rest:2.4.0 |
Affected Products
cuba platformhaulmontcuba rest apihaulmontjmix frameworkhaulmontjpa web apihaulmontDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.jmix.rest:jmix-rest, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.jmix.rest:jmix-rest to 1.6.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-32951 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2025-32951 in your dependencies?
Find it across Maven, including transitive dependencies.