NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2025-32019 — harbor

MEDIUMFix: goharbor/harbor@76c2c5f

CVE-2025-32019 is a medium-severity (CVSS 4.1) Cross-site Scripting (XSS) vulnerability in github.com/goharbor/harbor. A fix is available for github.com/goharbor/harbor — see the affected versions and patch details below.

Harbor's repository description page allows for XSS

Also known asBIT-harbor-2025-32019GHSA-f9vc-vf3r-pqqqGO-2025-3825
Published
Updated
Affected
4 pkgs
Patched
3 / 4
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-32019.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs31th percentile — riskier than 31% of all scored CVEsHighest risk
0.00%0.29%0.58%0.87%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐹github.com/goharbor/harbor🐹github.com/goharbor/harbor🐹github.com/goharbor/harbor🐹github.com/goharbor/harbor

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Harbor is an open source trusted cloud native registry project that stores, signs, and scans content. Versions 2.11.2 and below, as well as versions 2.12.0-rc1 and 2.13.0-rc1, contain a vulnerability where the markdown field in the info tab page can be exploited to inject XSS code. This is fixed in versions 2.11.3 and 2.12.3.

Affected Packages

4 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/goharbor/harbor≥ 2.12.0-rc1&&< 2.12.4-rc12.12.4-rc1go get github.com/goharbor/harbor@v2.12.4-rc1
🐹Gogithub.com/goharbor/harbor≥ 2.13.0-rc1&&< 2.13.1-rc12.13.1-rc1go get github.com/goharbor/harbor@v2.13.1-rc1
🐹Gogithub.com/goharbor/harbor≥ 2.4.0-rc1.1No fix
🐹Gogithub.com/goharbor/harborall versions2.4.0-rc1.0.20250421072404-a13a16383a41go get github.com/goharbor/harbor@v2.4.0-rc1.0.20250421072404-a13a16383a41

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/goharbor/harbor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/goharbor/harbor to 2.12.4-rc1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-32019 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Harbor is an open source trusted cloud native registry project that stores, signs, and scans content. Versions 2.11.2 and below, as well as versions 2.12.0-rc1 and 2.13.0-rc1, contain a vulnerability where the markdown field in the info tab page can be exploited to inject XSS code. This is fixed in versions 2.11.3 and 2.12.3.
O3 Security · Impact-Aware SCA

Is CVE-2025-32019 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2025-32019: harbor XSS — Fixed in 2.12.4-rc1