CVE-2024-22261 — harbor
LOWCVE-2024-22261 is a low-severity (CVSS 2.7) CWE-566 vulnerability in github.com/goharbor/harbor. A fix is available for github.com/goharbor/harbor — see the affected versions and patch details below.
SQL Injection in Harbor scan log API
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-22261.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/goharbor/harbor🐹github.com/goharbor/harbor🐹github.com/goharbor/harborReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A user with an administrator, project_admin, or project_maintainer role could utilize and exploit SQL Injection to allow the execution of any Postgres function or the extraction of sensitive information from the database through this API:
GET /api/v2.0/projects/{project_name}/repositories/{repository_name}/artifacts/{reference}/scan/{report_id}/log
The SQL injection might happen in the code:
Because raw SQL executed in ormer.Raw(Sql).QueryRows() is PrepareStatement. In the driver of Postgres, one PrepareStatement must contain only ONE SQL command, see https://www.postgresql.org/docs/15/libpq-exec.html#LIBPQ-PQPREPARE. The SQL should start with:
SELECT * FROM task WHERE extra_attrs::jsonb->'report_uuids' @>
Adding a delete/update operation by appending malicious content to the current SQL is impossible. Furthermore, the query result of the task is just an intermediate result, the task ID is used to locate the job log file, and the response only contains the content of the job log file. so this vulnerability can be used to execute SQL functions, but it can't leak any useful information to the response.
Harbor >=v2.8.1, >=2.9.0, >=2.10.0 are impacted.
Patches
Harbor v2.8.6, v2.9.4, v2.10.2 fixes this issue.
Workarounds
There is no workaround for this issue.
Credits
Thanks Taisei Inoue ([email protected])
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/goharbor/harbor | all versions | 2.8.6go get github.com/goharbor/harbor@v2.8.6 |
| 🐹Go | github.com/goharbor/harbor | ≥ 2.9.0&&< 2.9.4 | 2.9.4go get github.com/goharbor/harbor@v2.9.4 |
| 🐹Go | github.com/goharbor/harbor | ≥ 2.10.0&&< 2.10.2 | 2.10.2go get github.com/goharbor/harbor@v2.10.2 |
Affected Products
harborlinuxfoundationDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/goharbor/harbor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/goharbor/harbor to 2.8.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-22261 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2024-22261 in your dependencies?
Find it across Go, including transitive dependencies.