CVE-2025-31690 — cache_utility
HIGHCVE-2025-31690 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in drupal/cache_utility. A fix is available for drupal/cache_utility — see the affected versions and patch details below.
Cache Utility - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-019
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-31690.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/cache_utilityReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-Site Request Forgery (CSRF) vulnerability in Drupal Cache Utility allows Cross Site Request Forgery. This issue affects Cache Utility: from 0.0.0 before 1.2.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/cache_utility | all versions | 1.2.1composer require drupal/cache_utility:^1.2.1 |
Affected Products
cache utilitycache_utility_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/cache_utility, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/cache_utility to 1.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-31690 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-31690 in your dependencies?
Find it across Packagist, including transitive dependencies.