NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2025-31682 — google_tag

MEDIUM

CVE-2025-31682 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in drupal/google_tag. A fix is available for drupal/google_tag — see the affected versions and patch details below.

Google Tag - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-011

Also known asDRUPAL-CONTRIB-2025-011GHSA-36vv-q5jv-94cj
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-31682.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs15th percentile — riskier than 15% of all scored CVEsHighest risk
0.00%0.30%0.59%0.89%0.4%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘drupal/google_tag🐘drupal/google_tag

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Google Tag allows Cross-Site Scripting (XSS). This issue affects Google Tag: from 0.0.0 before 1.8.0, from 2.0.0 before 2.0.8.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdrupal/google_tagall versions1.8.0composer require drupal/google_tag:^1.8.0
🐘Packagistdrupal/google_tag≥ 2.0.0&&< 2.0.82.0.8composer require drupal/google_tag:^2.0.8

Affected Products

1 product · 2 configurations
Application
google taggoogle_tag_project
≥ 2.0.0 && < 2.0.8
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/google_tag, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/google_tag to 1.8.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-31682 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Google Tag allows Cross-Site Scripting (XSS). This issue affects Google Tag: from 0.0.0 before 1.8.0, from 2.0.0 before 2.0.8.
O3 Security · Impact-Aware SCA

Is CVE-2025-31682 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2025-31682: google_tag XSS — Fixed in 1.8.0