NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2025-31675 — core

MEDIUM

CVE-2025-31675 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.

Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2025-004

Also known asBIT-drupal-2025-31675DRUPAL-CORE-2025-004GHSA-m4wj-hhwj-47qp
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-31675.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs43th percentile — riskier than 43% of all scored CVEsHighest risk
0.00%0.33%0.67%1.00%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘drupal/core🐘drupal/core🐘drupal/core🐘drupal/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.14, from 10.4.0 before 10.4.5, from 11.0.0 before 11.0.13, from 11.1.0 before 11.1.5. It also affects the Drupal 7 module from versions 7.x-1.0 through 7.x-1.12.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdrupal/core≥ 8.0.0&&< 10.3.1410.3.14composer require drupal/core:^10.3.14
🐘Packagistdrupal/core≥ 10.4.0&&< 10.4.510.4.5composer require drupal/core:^10.4.5
🐘Packagistdrupal/core≥ 11.0.0&&< 11.0.1311.0.13composer require drupal/core:^11.0.13
🐘Packagistdrupal/core≥ 11.1.0&&< 11.1.511.1.5composer require drupal/core:^11.1.5

Affected Products

1 product · 4 configurations
Application
drupaldrupal
≥ 11.1.0 && < 11.1.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/core to 10.3.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-31675 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.14, from 10.4.0 before 10.4.5, from 11.0.0 before 11.0.13, from 11.1.0 before 11.1.5. It also affects the Drupal 7 module from versions 7.x-1.0 through 7.x-1.12.
O3 Security · Impact-Aware SCA

Is CVE-2025-31675 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2025-31675: core XSS — Fixed in 10.3.14