CVE-2025-31137 — @react-router/express
HIGHCVE-2025-31137 is a high-severity (CVSS 7.5) CWE-444 vulnerability in @react-router/express. A fix is available for @react-router/express — see the affected versions and patch details below.
Remix and React Router allow URL manipulation via Host / X-Forwarded-Host headers
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-31137.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@react-router/expressnpm@remix-run/expressnpmDescription
React Router is a multi-strategy router for React bridging the gap from React 18 to React 19. There is a vulnerability in Remix/React Router that affects all Remix 2 and React Router 7 consumers using the Express adapter. Basically, this vulnerability allows anyone to spoof the URL used in an incoming Request by putting a URL pathname in the port section of a URL that is part of a Host or X-Forwarded-Host header sent to a Remix/React Router request handler. This issue has been patched and released in Remix 2.16.3 and React Router 7.4.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @react-router/express | ≥ 7.0.0&&< 7.4.1 | 7.4.1npm install @react-router/express@7.4.1 |
| 📦npm | @remix-run/express | ≥ 2.11.1&&< 2.16.3 | 2.16.3npm install @remix-run/express@2.16.3 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @react-router/express, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @react-router/express to 7.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-31137 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability allows URL spoofing, which can lead to unauthorized access to resources and potential data breaches. The fact that it requires no authentication or user interaction significantly increases its exploitability. The use of Host or X-Forwarded-Host headers, which are commonly used in web applications,…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2025-31137 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2025-31137 in your dependencies?
Find it across npm, including transitive dependencies.