CVE-2025-30163 is a low-severity (CVSS 3.4) CWE-863 vulnerability in github.com/cilium/cilium. A fix is available for github.com/cilium/cilium — see the affected versions and patch details below.
Node based network policies may incorrectly allow workload traffic
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-30163.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/cilium/cilium🐹github.com/cilium/ciliumReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Node based network policies (fromNodes and toNodes) will incorrectly permit traffic to/from non-node endpoints that share the labels specified in fromNodes and toNodes sections of network policies. Node based network policy is disabled by default in Cilium.
Patches
This issue was fixed by https://github.com/cilium/cilium/pull/36657.
This issue affects:
- Cilium v1.16 between v1.16.0 and v1.16.7 inclusive
- Cilium v1.17 between v1.17.0 and v1.17.1 inclusive
This issue is fixed in:
- Cilium v1.16.8
- Cilium v1.17.2
Workarounds
Users can work around this issue by ensuring that the labels used in fromNodes and toNodes fields are used exclusively by nodes and not by other endpoints.
Acknowledgements
The Cilium community has worked together with members of Isovalent to prepare these mitigations. Special thanks to @oblazek for reporting and fixing this issue.
For more information
If you think you have found a vulnerability affecting Cilium, we strongly encourage you to report it to our security mailing list at [email protected]. This is a private mailing list for the Cilium security team, and your report will be treated as top priority. Please also address any comments or questions on this advisory to the same mailing list.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/cilium/cilium | ≥ 1.16.0&&< 1.16.8 | 1.16.8go get github.com/cilium/cilium@v1.16.8 |
| 🐹Go | github.com/cilium/cilium | ≥ 1.17.0&&< 1.17.2 | 1.17.2go get github.com/cilium/cilium@v1.17.2 |
Affected Products
ciliumciliumDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/cilium/cilium, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/cilium/cilium to 1.16.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-30163 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The vulnerability affects Cilium's node-based network policies (fromNodes and toNodes). The Attack Complexity is set to High (AC:H) because node-based network policy is disabled by default in Cilium. For an attack to succeed, an administrator must first explicitly enable this non-default feature, and the environment…
Users can work around this issue by ensuring that the labels used in `fromNodes` and `toNodes` fields are used exclusively by nodes and not by other endpoints.Source: Red Hat security advisory for CVE-2025-30163 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2025-30163 in your dependencies?
Find it across Go, including transitive dependencies.