CVE-2025-27888 — druid
CVE-2025-27888 is a Cross-site Scripting (XSS) vulnerability in org.apache.druid:druid. A fix is available for org.apache.druid:druid — see the affected versions and patch details below.
Apache Druid: Server-Side Request Forgery and Cross-Site Scripting
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-27888.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.druid:druid☕org.apache.druid:druidReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Severity: medium (5.8) / important
Server-Side Request Forgery (SSRF), Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'), URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Apache Druid.
This issue affects all previous Druid versions.
When using the Druid management proxy, a request that has a specially crafted URL could be used to redirect the request to an arbitrary server instead. This has the potential for XSS or XSRF. The user is required to be authenticated for this exploit. The management proxy is enabled in Druid's out-of-box configuration. It may be disabled to mitigate this vulnerability. If the management proxy is disabled, some web console features will not work properly, but core functionality is unaffected.
Users are recommended to upgrade to Druid 31.0.2 or Druid 32.0.1, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.druid:druid | all versions | 31.0.2org.apache.druid:druid:31.0.2 |
| ☕Maven | org.apache.druid:druid | ≥ 32.0.0&&< 32.0.1 | 32.0.1org.apache.druid:druid:32.0.1 |
Affected Products
druidapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.druid:druid, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.druid:druid to 31.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-27888 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
How to detect CVE-2025-27888
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2025-27888 -u https://target- Template
- Apache Druid - Server-Side Request Forgery
- Severity
- high
- Impact
- Authenticated attackers can exploit SSRF vulnerabilities through the management proxy to redirect requests to arbitrary servers, potentially enabling XSS, XSRF attacks, or accessing internal services.
- Remediation
- Upgrade to Apache Druid version 31.0.2 or 32.0.1, or disable the management proxy to mitigate this vulnerability.
Template by ProjectDiscovery nuclei-templates (xbow, DhiyaneshDK), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2025-27888 in your dependencies?
Find it across Maven, including transitive dependencies.