CVE-2025-27611 — base-x
Fix: cryptocoinjs/base-x#86CVE-2025-27611 is a CWE-1007 vulnerability in base-x. A fix is available for base-x — see the affected versions and patch details below.
base-x homograph attack allows Unicode lookalike characters to bypass validation.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-27611.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
base-xnpmDescription
base-x is a base encoder and decoder of any given alphabet using bitcoin style leading zero compression. Versions 4.0.0, 5.0.0, and all prior to 3.0.11, are vulnerable to attackers potentially deceiving users into sending funds to an unintended address. This issue has been patched in versions 3.0.11, 4.0.1, and 5.0.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | base-x | ≥ 5.0.0&&< 5.0.1 | 5.0.1npm install base-x@5.0.1 |
| 📦npm | base-x | ≥ 4.0.0&&< 4.0.1 | 4.0.1npm install base-x@4.0.1 |
| 📦npm | base-x | all versions | 3.0.11npm install base-x@3.0.11 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for base-x, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update base-x to 5.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-27611 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability in base-x is Important because it affects the encoding and decoding of addresses in blockchain transactions. The flaw arises from mishandling of leading zero compression, enabling attackers to craft malicious encodings that deceive systems or users into misdirecting funds. As blockchain transactions…
No mitigation is currently available that meets Red Hat Product Security’s standards for usability, deployment, applicability, or stability.Source: Red Hat security advisory for CVE-2025-27611 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss Enterprise Application Platform 8.0.8 | org.jboss.hal-hal-parent | RHSA-2025:10459 |
| Red Hat JBoss Enterprise Application Platform 8.0 for RHEL 8 | eap8-activemq-artemis-0:2.33.0-3.redhat_00017.1.el8eap | RHSA-2025:10452 |
| Red Hat JBoss Enterprise Application Platform 8.0 for RHEL 9 | eap8-activemq-artemis-0:2.33.0-3.redhat_00017.1.el9eap | RHSA-2025:10453 |
Frequently Asked Questions
Is CVE-2025-27611 in your dependencies?
Find it across npm, including transitive dependencies.