NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2025-26791 — dompurify

MEDIUMFix: cure53/DOMPurify@d18ffcb

CVE-2025-26791 is a medium-severity (CVSS 4.5) Cross-site Scripting (XSS) vulnerability in dompurify. A fix is available for dompurify — see the affected versions and patch details below.

DOMPurify allows Cross-site Scripting (XSS)

Also known asGHSA-vhxf-7vqr-mrjg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-26791.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs49th percentile — riskier than 49% of all scored CVEsHighest risk
0.00%0.37%0.74%1.10%0.1%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

6Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
dompurifynpm
99.6Mdownloads / week

Description

DOMPurify before 3.2.4 has an incorrect template literal regular expression when SAFE_FOR_TEMPLATES is set to true, sometimes leading to mutation cross-site scripting (mXSS).

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmdompurifyall versions3.2.4npm install dompurify@3.2.4

Affected Products

1 product · 1 configurations
Application
dompurifycure53
< 3.2.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dompurify, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update dompurify to 3.2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-26791 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Ansible Automation Platform 2.5 for RHEL 8automation-gateway-0:2.5.20250312-1.el8apRHSA-2025:2518
Red Hat Ceph Storage 7.1ceph-2:18.2.1-381.el8cpRHSA-2026:2769
Red Hat OpenShift Service Mesh 2.5 for RHEL 8openshift-service-mesh/kiali-ossmc-rhel8:1.73.18-2RHSA-2025:1875
Red Hat Ceph Storage 8rhceph/grafana-rhel9:1770630607RHSA-2026:2737
Red Hat Ceph Storage 9rhceph/grafana-rhel10:1771399331RHSA-2026:3406
Red Hat Ceph Storage 9.2rhceph/rhceph-9-rhel10:1790843527RHSA-2026:86618
Red Hat Developer Hub 1.6rhdh/rhdh-hub-rhel9:1.6.0-1745956724RHSA-2025:7626
Red Hat OpenShift AI 2.16rhoai/odh-dashboard-rhel8:v2.16.2-1741963152RHSA-2025:3368

Frequently Asked Questions

DOMPurify before 3.2.4 has an incorrect template literal regular expression when SAFE_FOR_TEMPLATES is set to true, sometimes leading to mutation cross-site scripting (mXSS).
O3 Security · Impact-Aware SCA

Is CVE-2025-26791 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2025-26791: dompurify XSS — Fixed in 3.2.4