CVE-2025-25299 — @ckeditor/ckeditor5-real-…
CVE-2025-25299 is a Cross-site Scripting (XSS) vulnerability in @ckeditor/ckeditor5-real-time-collaboration. A fix is available for @ckeditor/ckeditor5-real-time-collaboration — see the affected versions and patch details below.
Cross-site scripting (XSS) in the real-time collaboration package
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@ckeditor/ckeditor5-real-time-collaborationnpmckeditor5-premium-featuresnpmDescription
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. During a recent internal audit, a Cross-Site Scripting (XSS) vulnerability was discovered in the CKEditor 5 real-time collaboration package. This vulnerability affects user markers, which represent users' positions within the document. It can lead to unauthorized JavaScript code execution, which might happen with a very specific editor and token endpoint configuration. This vulnerability affects only installations with Real-time collaborative editing enabled. The problem has been recognized and patched. The fix is available in version 44.2.1 (and above). Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @ckeditor/ckeditor5-real-time-collaboration | ≥ 41.3.0&&< 44.2.1 | 44.2.1npm install @ckeditor/ckeditor5-real-time-collaboration@44.2.1 |
| 📦npm | ckeditor5-premium-features | ≥ 42.0.0&&< 44.2.1 | 44.2.1npm install ckeditor5-premium-features@44.2.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @ckeditor/ckeditor5-real-time-collaboration, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @ckeditor/ckeditor5-real-time-collaboration to 44.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-25299 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2025-25299 in your dependencies?
Find it across npm, including transitive dependencies.