CVE-2025-25197 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in dnadesign/silverstripe-elemental. A fix is available for dnadesign/silverstripe-elemental — see the affected versions and patch details below.
Silverstripe Elemental enables XSS attacks in elemental "Content blocks in use" reports
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-25197.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
dnadesign/silverstripe-elementalReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Silverstripe Elemental extends a page type to swap the content area for a list of manageable elements to compose a page out of rather than a single text field. An elemental block can include an XSS payload, which can be executed when viewing the "Content blocks in use" report. The vulnerability is specific to that report and is a result of failure to cast input prior to including it in the grid field. This vulnerability is fixed in 5.3.12.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | dnadesign/silverstripe-elemental | ≥ 2.1.2&&< 5.3.12 | 5.3.12composer require dnadesign/silverstripe-elemental:^5.3.12 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dnadesign/silverstripe-elemental, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update dnadesign/silverstripe-elemental to 5.3.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-25197 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2025-25197 in your dependencies?
Find it across Packagist, including transitive dependencies.