CVE-2025-24986 is a medium-severity (CVSS 6.5) CWE-653 vulnerability in promptflow-tools. A fix is available for promptflow-tools — see the affected versions and patch details below.
Azure PromptFlow remote code execution related to Jinja templates
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-24986.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
promptflow-tools🐍promptflow-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Improper isolation or compartmentalization in Azure PromptFlow allows an unauthorized attacker to execute code over a network.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | promptflow-tools | all versions | 1.6.0pip install --upgrade 'promptflow-tools==1.6.0' |
| 🐍PyPI | promptflow-core | all versions | 1.17.2pip install --upgrade 'promptflow-core==1.17.2' |
Affected Products
azure promptflow coremicrosoftazure promptflow toolsmicrosoftDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for promptflow-tools, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update promptflow-tools to 1.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-24986 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-24986 in your dependencies?
Find it across PyPI, including transitive dependencies.