NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2025-23368 — wildfly-elytron-integrati…

HIGHFix: wildfly/wildfly-core#6634

CVE-2025-23368 is a high-severity (CVSS 8.1) CWE-307 vulnerability in org.wildfly.core:wildfly-elytron-integration. A fix is available for org.wildfly.core:wildfly-elytron-integration — see the affected versions and patch details below.

Org.wildfly.core:wildfly-elytron-integration: wildfly elytron brute force attack via cli

Also known asGHSA-qhp6-6p8p-2rqh
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-23368.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.46%0.92%1.39%0.2%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.wildfly.core:wildfly-elytron-integration☕org.wildfly.core:wildfly-elytron-integration

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

A flaw was found in Wildfly Elytron integration. The component does not implement sufficient measures to prevent multiple failed authentication attempts within a short time frame, making it more susceptible to brute force attacks via CLI.

Patches

The default behaviour has been changed in WildFly Core 31.0.3.Final, and 32.0.0.Beta3 - the first version is used by WildFly 39.0.1.Final and the second will be included in WildFly 40.

Workarounds

No direct workaround. Monitoring network traffic / blocking suspicious traffic may help.

References

https://www.cve.org/CVERecord?id=CVE-2025-23368 https://issues.redhat.com/browse/WFCORE-7192

Acknowledgements

We would like to thank Claudia Bartolini (TIM S.p.A), Marco Ventura (TIM S.p.A), and Massimiliano Brolli (TIM S.p.A) for reporting this issue.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.wildfly.core:wildfly-elytron-integration≥ 32.0.0.Beta1&&< 32.0.0.Beta332.0.0.Beta3org.wildfly.core:wildfly-elytron-integration:32.0.0.Beta3
☕Mavenorg.wildfly.core:wildfly-elytron-integrationall versions31.0.3.Finalorg.wildfly.core:wildfly-elytron-integration:31.0.3.Final

Affected Products

3 products · 4 configurations
Application
data gridredhat
1 version
8.0
Application
jboss enterprise application platformredhat
2 versions
7.0.08.0.0
Application
wildfly coreredhat
< 31.0.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.wildfly.core:wildfly-elytron-integration, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.wildfly.core:wildfly-elytron-integration to 32.0.0.Beta3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-23368 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

According to WildFly Elytron, this affects all versions of JBoss EAP from version 7.1. Red Hat build of Keycloak does not ship wildfly-elytron.

Workaround published by Red Hat
The effectiveness of an attack will also be dependent on the complexity of the usernames and passwords defined for the target installation.
Source: Red Hat security advisory for CVE-2025-23368 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat JBoss Enterprise Application Platform 7.3 EUS for RHEL 7eap7-wildfly-0:7.3.18-3.GA_redhat_00001.1.el7eapRHSA-2026:33371
Red Hat JBoss Enterprise Application Platform 8.1.6.GAorg.wildfly.core/wildfly-elytron-integration:27.1.9.Final-redhat-00002RHSA-2026:18059
Red Hat JBoss Enterprise Application Platform 8.1 for RHEL 8eap8-wildfly-0:8.1.6-5.GA_redhat_00007.1.el8eapRHSA-2026:18054
Red Hat JBoss Enterprise Application Platform 8.1 for RHEL 9eap8-wildfly-0:8.1.6-5.GA_redhat_00007.1.el9eapRHSA-2026:18055

Frequently Asked Questions

### Impact A flaw was found in Wildfly Elytron integration. The component does not implement sufficient measures to prevent multiple failed authentication attempts within a short time frame, making it more susceptible to brute force attacks via CLI. ### Patches The default behaviour has been changed in WildFly Core 31.0.3.Final, and 32.0.0.Beta3 - the first version is used by WildFly 39.0.1.Final and the second will be included in WildFly 40. ### Workarounds No direct workaround. Monitoring network traffic / blocking suspicious traffic may help. ### References https://www.cve.org/CVERec
O3 Security · Impact-Aware SCA

Is CVE-2025-23368 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-23368: wildfly-elytron — Fixed in 32.0.0.Beta3