CVE-2025-23081 — data-transfer
CVE-2025-23081 is a Cross-site Scripting (XSS) vulnerability in mediawiki/data-transfer. A fix is available for mediawiki/data-transfer — see the affected versions and patch details below.
Mediawiki - DataTransfer Extension Cross-Site Request Forgery (CSRF) and Cross-site Scripting (XSS)
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-23081.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
mediawiki/data-transfer🐘mediawiki/data-transfer🐘mediawiki/data-transferReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-Site Request Forgery (CSRF), Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - DataTransfer Extension allows Cross Site Request Forgery, Cross-Site Scripting (XSS).This issue affects Mediawiki - DataTransfer Extension: from 1.39.X before 1.39.11, from 1.41.X before 1.41.3, from 1.42.X before 1.42.2.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | mediawiki/data-transfer | ≥ 1.39.0&&< 1.39.11 | 1.39.11composer require mediawiki/data-transfer:^1.39.11 |
| 🐘Packagist | mediawiki/data-transfer | ≥ 1.41.0&&< 1.41.3 | 1.41.3composer require mediawiki/data-transfer:^1.41.3 |
| 🐘Packagist | mediawiki/data-transfer | ≥ 1.42.0&&< 1.42.2 | 1.42.2composer require mediawiki/data-transfer:^1.42.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/data-transfer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mediawiki/data-transfer to 1.39.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-23081 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2025-23081 in your dependencies?
Find it across Packagist, including transitive dependencies.