CVE-2025-1398 — mattermost-desktop
LOWCVE-2025-1398 is a low-severity (CVSS 3.3) CWE-426 vulnerability in mattermost-desktop. A fix is available for mattermost-desktop — see the affected versions and patch details below.
macOS TCC Bypass via Code Injection
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-1398.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
mattermost-desktopnpmDescription
Mattermost Desktop App versions <=5.10.0 explicitly declared unnecessary macOS entitlements which allows an attacker with remote access to bypass Transparency, Consent, and Control (TCC) via code injection.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | mattermost-desktop | all versions | 5.11.0npm install mattermost-desktop@5.11.0 |
Affected Products
mattermost desktopmattermostDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mattermost-desktop, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mattermost-desktop to 5.11.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-1398 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2025-1398 in your dependencies?
Find it across npm, including transitive dependencies.