CVE-2024-39772 — mattermost-desktop
LOWCVE-2024-39772 is a low-severity (CVSS 3.7) CWE-284 vulnerability in mattermost-desktop. A fix is available for mattermost-desktop — see the affected versions and patch details below.
Silent Desktop Screenshot Capture
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-39772.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
mattermost-desktopnpmDescription
Mattermost Desktop App versions <=5.8.0 fail to safeguard screen capture functionality which allows an attacker to silently capture high-quality screenshots via JavaScript APIs.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | mattermost-desktop | all versions | 5.9.0npm install mattermost-desktop@5.9.0 |
Affected Products
mattermost desktopmattermostDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mattermost-desktop, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mattermost-desktop to 5.9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-39772 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2024-39772 in your dependencies?
Find it across npm, including transitive dependencies.