CVE-2025-13324 is a low-severity (CVSS 3.7) CWE-863 vulnerability in github.com/mattermost/mattermost. A fix is available for github.com/mattermost/mattermost — see the affected versions and patch details below.
Lack of Invalidation of Legacy Remote Cluster Invite Tokens After Confirmation
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-13324.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/mattermost/mattermost🐹github.com/mattermost/mattermost🐹github.com/mattermost/mattermost🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Mattermost versions 10.11.x <= 10.11.5, 11.0.x <= 11.0.4, 10.12.x <= 10.12.2 fail to invalidate remote cluster invite tokens when using the legacy (version 1) protocol or when the confirming party does not provide a refreshed token, which allows an attacker who has obtained an invite token to authenticate as the remote cluster and perform limited actions on shared channels even after the invitation has been legitimately confirmed.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/mattermost/mattermost | ≥ 10.12.0&&< 10.12.2 | 10.12.2go get github.com/mattermost/mattermost@v10.12.2 |
| 🐹Go | github.com/mattermost/mattermost | ≥ 10.11.0-rc1&&< 10.11.5 | 10.11.5go get github.com/mattermost/mattermost@v10.11.5 |
| 🐹Go | github.com/mattermost/mattermost | ≥ 11.0.0-alpha.1&&< 11.0.4 | 11.0.4go get github.com/mattermost/mattermost@v11.0.4 |
| 🐹Go | github.com/mattermost/mattermost/server/v8 | all versions | 8.0.0-20251031095924-e7e23b94e006go get github.com/mattermost/mattermost/server/v8@v8.0.0-20251031095924-e7e23b94e006 |
| 🐹Go | github.com/mattermost/mattermost-server | all versions | 11.0.4go get github.com/mattermost/mattermost-server@v11.0.4 |
Affected Products
mattermost servermattermostDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/mattermost/mattermost to 10.12.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-13324 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2025-13324 in your dependencies?
Find it across Go, including transitive dependencies.