NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
LOW severity

CVE-2024-41926 — server

LOWFix: mattermost/mattermost@5114c3b

CVE-2024-41926 is a low-severity (CVSS 2.7) CWE-284 vulnerability in github.com/mattermost/mattermost/server/v8. A fix is available for github.com/mattermost/mattermost/server/v8 — see the affected versions and patch details below.

Malicious remote can claim that a user was synced from another remote

Also known asBIT-mattermost-2024-41926GHSA-9fpw-c9x7-cv3jGO-2024-3022
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-41926.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs7th percentile — riskier than 7% of all scored CVEsHighest risk
0.00%0.22%0.45%0.68%0.2%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost versions 9.9.x <= 9.9.0 and 9.5.x <= 9.5.6 fail to validate the source of sync messages and only allow the correct remote IDs, which allows a malicious remote to set arbitrary RemoteId values for synced users and therefore claim that a user was synced from another remote.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 9.5.0&&< 9.5.79.5.7go get github.com/mattermost/mattermost/server/v8@v9.5.7
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 9.9.0&&< 9.9.19.9.1go get github.com/mattermost/mattermost/server/v8@v9.9.1
🐹Gogithub.com/mattermost/mattermost/server/v8all versions8.0.0-20240604093018-5114c3b7cdb8go get github.com/mattermost/mattermost/server/v8@v8.0.0-20240604093018-5114c3b7cdb8
🐹Gogithub.com/mattermost/mattermostall versions5.3.2-0.20240604093018-5114c3b7cdb8go get github.com/mattermost/mattermost@v5.3.2-0.20240604093018-5114c3b7cdb8

Affected Products

1 product · 2 configurations
Application
mattermost servermattermost
≥ 9.5.0 && < 9.5.7
1 version
9.9.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost/server/v8, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost/server/v8 to 9.5.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-41926 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Mattermost versions 9.9.x <= 9.9.0 and 9.5.x <= 9.5.6 fail to validate the source of sync messages and only allow the correct remote IDs, which allows a malicious remote to set arbitrary RemoteId values for synced users and therefore claim that a user was synced from another remote.
O3 Security · Impact-Aware SCA

Is CVE-2024-41926 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2024-41926: server — Fixed in 9.5.7